summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pytest-mock
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest4
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.4.0.ebuild36
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.5.1.ebuild2
3 files changed, 2 insertions, 40 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 7d760fcabef1..087cf63faf76 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-mock-3.4.0.tar.gz 28115 BLAKE2B 0a7f9098955d57f7121c04f7ab706dd67eb52d8ec0b2254552460eb90b2e3fef3cd3b925cf46619532ffe7bede2f208bf822e465647f3ac4504566c18ff58a75 SHA512 5456b60bdd06a63859232b28aeb79be643e8298e69ae103cb6e194891987e01b17771ad895dfead97fa45531959689fb202bb1ebc9ba44491098760c10d1ef43
DIST pytest-mock-3.5.1.tar.gz 29135 BLAKE2B f9eb37bff0965772919c359ad56a0cdd0cac24fa763685c42ffaa2dfaea183a9c0be480269cbfc80990baaf406021c541b6dccc09602e98c8f731bbd530e928a SHA512 28ab2f239d3dfee134dd4e4fd467109cf3c76cb60aeb537dbc0c21b9a7619d068d54737e33d98c585e9341588fdafba4737ea5f428af37796f55e61ec30373a7
-EBUILD pytest-mock-3.4.0.ebuild 953 BLAKE2B af318c499a1dbbdc22f44d9349b63869558eb92d035dca81c9599bfca4d5a43365242f63e57e0b81a21496982fd125e44d09d0e0cc4d80ab4cae48b4022a6dc4 SHA512 197716c13d3b10d3ba5db4b432a5a522649adfdf2badbe93f916afd9bd14d3b31427a94a8f213aaf22f96da49e69668598553b46bc28fe01ddfdf22dabed01df
-EBUILD pytest-mock-3.5.1.ebuild 961 BLAKE2B b9141a1cb20bedd2aa0dbdca793d5cd33acc09ff15526ff9e60c2cbab6c546c93bb0f70df1e2c95b8c1927c206e399c7178e7d9d9d120e59a7f7f4b8aa3d3a0a SHA512 f13eff6316dd71a0a33bc4b86fb411aeffc4416ea6ed2573ae32af9927a951cc99ea82166d1a00b9348159bc5a5cb8bdaf88437b2912653451d1263b3bd72d14
+EBUILD pytest-mock-3.5.1.ebuild 953 BLAKE2B af318c499a1dbbdc22f44d9349b63869558eb92d035dca81c9599bfca4d5a43365242f63e57e0b81a21496982fd125e44d09d0e0cc4d80ab4cae48b4022a6dc4 SHA512 197716c13d3b10d3ba5db4b432a5a522649adfdf2badbe93f916afd9bd14d3b31427a94a8f213aaf22f96da49e69668598553b46bc28fe01ddfdf22dabed01df
MISC metadata.xml 457 BLAKE2B 9ec62ff0eda60ae60bb1b63509ecc696ae4256d1b3ff00c9b7f834ffd735f87edef57ccbfb78a2f9002632c4287b581a8a81003c45601b314059675a8f2d288d SHA512 0defca8aefe2c6bb95d36112b14645d93c8bc5b8db08956b97b9a42cf4a7e1d97170068937e6ec818e43d4d6afd7ef414e1d5d7f4b72bae71291eeda9caf5c1a
diff --git a/dev-python/pytest-mock/pytest-mock-3.4.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.4.0.ebuild
deleted file mode 100644
index 17ca5abbe94f..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.4.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- if has_version dev-python/mock; then
- # test fails when standalone mock is installed
- sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
- fi
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
- pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
index fc5daaeaf104..17ca5abbe94f 100644
--- a/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.5.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
IUSE=""
RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"