summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-03 17:44:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-03 17:44:31 +0000
commitc44123f79f40edf5fe3d4b0d211d6aa68542abd2 (patch)
tree838edea4b7f78b425eacf44f29775ffd0bc671e3 /dev-python/pytest-mock
parent79e5685b8db7602719212510574962664af2b036 (diff)
gentoo auto-resync : 03:02:2024 - 17:44:31
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest3
-rw-r--r--dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch34
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.12.0.ebuild7
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 4aca20be3776..7dd4cd90565c 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1,4 @@
+AUX pytest-mock-3.12.0-test.patch 1460 BLAKE2B 890582314f162041e1534e788590987f7979c5f00590d4ae3af15f0f2f1f6a3a11a6c3405421c2a4b5bc56a4ad425f513c73e73bdaba7cf03b06bbaac9ee97dd SHA512 bf20ac46065b8b0ba206dad81a0d34b4a8965c53d6087b9ea010b49e0f64ca5ab960a58cbef6a6940fd7d3f167648e5b6908dff1a8803f296329f0c67fc7cbaa
DIST pytest-mock-3.12.0.tar.gz 32139 BLAKE2B 4bc2289579686b8ca9e840440b21b7299817e803f108726692cda6f1a138564462b04b9ae6a3038a5e36ec4d665bb7c8f54c26d231d6b17188b8d830d553b20d SHA512 6da429e646a4e3a825f699969dbc87033136918bd9aa111ff334fac324e5ac89ef6516e82ffeeb20cb6a857fbbe904d8ee985acefba2d2b7bd0ffe4b9227ad82
-EBUILD pytest-mock-3.12.0.ebuild 1235 BLAKE2B 86631d6db534c3f1387249cab08f14907b3bde25b80c12569d016cb56f3154db7b214f5bd95f88f4af15d82cb29c9ae36cb6c2d57ac4bfdbb8e36a0bb2c93496 SHA512 e467081ebfc9673a5dcf9ccfd9f1a96a8b5df6f82a7e8499c980376c5e2b781f8398877068dc97f00da2387185756bf2ab1aaeea3a979545abb512c5001fb263
+EBUILD pytest-mock-3.12.0.ebuild 1333 BLAKE2B d05478e086727ceecd2eb0226c632f6e2c72fbb21bc15303c4df6e3b296b0e62b3d27ee66017c256a30fcf74cbc49786239ecd67acadcb15087095501ce5c896 SHA512 aaaf236803ed9c3fc9e1000904d6e929d789b3670ebd87e031ad5226e8169ac5e611eefbeb4b7aec07ee090fa01a31e09fd594089955f25e8ced6ab38bee29a1
MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch b/dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch
new file mode 100644
index 000000000000..e3938fb1457c
--- /dev/null
+++ b/dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch
@@ -0,0 +1,34 @@
+From 39547ecdc051123750dd17a890c0492ac5d5b1a0 Mon Sep 17 00:00:00 2001
+From: Daniel Garcia Moreno <daniel.garcia@suse.com>
+Date: Wed, 20 Dec 2023 13:39:14 +0100
+Subject: [PATCH] Update expected message to match python 3.11.7
+
+https://github.com/python/cpython/issues/111019
+---
+ tests/test_pytest_mock.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
+index c185f2a..01534a4 100644
+--- a/tests/test_pytest_mock.py
++++ b/tests/test_pytest_mock.py
+@@ -25,6 +25,8 @@
+
+ # Python 3.8 changed the output formatting (bpo-35500), which has been ported to mock 3.0
+ NEW_FORMATTING = sys.version_info >= (3, 8)
++# Python 3.11.7 changed the output formatting, https://github.com/python/cpython/issues/111019
++NEWEST_FORMATTING = sys.version_info >= (3, 11, 7)
+
+ if sys.version_info[:2] >= (3, 8):
+ from unittest.mock import AsyncMock
+@@ -240,7 +242,9 @@ def test_repr_with_name(self, mocker: MockerFixture) -> None:
+
+ def __test_failure_message(self, mocker: MockerFixture, **kwargs: Any) -> None:
+ expected_name = kwargs.get("name") or "mock"
+- if NEW_FORMATTING:
++ if NEWEST_FORMATTING:
++ msg = "expected call not found.\nExpected: {0}()\n Actual: not called."
++ elif NEW_FORMATTING:
+ msg = "expected call not found.\nExpected: {0}()\nActual: not called."
+ else:
+ msg = "Expected call: {0}()\nNot called"
diff --git a/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
index 21e83bfc0670..ccb417b563d1 100644
--- a/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,6 +34,11 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/pytest-dev/pytest-mock/pull/404
+ "${FILESDIR}/${P}-test.patch"
+)
+
python_test() {
if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
einfo "Skipping tests on ${EPYTHON}"