summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 21:15:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 21:15:05 +0100
commitbd7d7f7f69423122e08209eefb1a8fa1d363e35e (patch)
tree0e400772206f4eb6774b2790628119c0f89ffd49 /dev-python/pytest-mock
parente4faa07b4eb2f5e4f9756d33924b318b1349956a (diff)
gentoo auto-resync : 28:09:2022 - 21:15:04
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.9.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 830906b15350..03bf39be543b 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1,5 @@
DIST pytest-mock-3.8.2.tar.gz 27734 BLAKE2B feaa92ba63626d7510008c41491bd0ab649b2a0cb55c888a472a5f6100a18d8b4a232532b6b3a860483bfd1676fc1216ca368e215b8f11fc6211eeef62f5743f SHA512 039342de6a22921ebac3f54a1f217a7a5d4cf9833ce4b4bee0a18ba5409d46211cd2d9ff9620a1576560d32f5e5799483e6686e3b58d32123f41dcd7a862154b
+DIST pytest-mock-3.9.0.tar.gz 27883 BLAKE2B d1cf4599bdc3fa21df83874c26751791f9ec891184baa2a304a8d4e48e5a03194718afb80e9019f914150ef22c1b3a787ac17cfadf10deae5584b8e39e32e376 SHA512 ed918574852ac70d863589d976fd65ac57c61ee1fa072651b93ee58f2d1154cef6c0ae1c2cba822bb1c6a2bddd6442b49e256652e2bd55fd3b1bed73017ff7b6
EBUILD pytest-mock-3.8.2.ebuild 1059 BLAKE2B a16270f47039f3c785b0ab4887a8d254ef0c2ddbd9f3f47eee3c836aa306bd6c753527b46000a27cd52828ab721314b334e27b5058cb807316f6148cf7768248 SHA512 3c944b84e9242582e3e773d491d732bb16952e53e1948a73eb475d11420dc040042552b23048124dc43a709d8fbf3982bf645ed2e95ae2642596be1b1d3fa09b
+EBUILD pytest-mock-3.9.0.ebuild 1067 BLAKE2B 2054d7347b138717e9c83954c1c813a52b09081e375fe73de0bfa6dba9881656f54921a7a0c63d030e62abeb74c4ba4295cb58196af46801abc3e511c6dc33dc SHA512 427607c7a44bed7a2f47593ca67db71ec97f809dd91ceba04cd4fac564f041a22aa1d7d4ba0dd544bbbe465a4db21c6c4487bf4d857b1ac9b4777f91d495fdb4
MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/pytest-mock-3.9.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.9.0.ebuild
new file mode 100644
index 000000000000..ce9187b4e2e5
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.9.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-mock/
+ https://pypi.org/project/pytest-mock/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
+ local EPYTEST_DESELECT=()
+
+ if has_version dev-python/mock; then
+ EPYTEST_DESELECT+=(
+ tests/test_pytest_mock.py::test_standalone_mock
+ )
+ fi
+
+ epytest --assert=plain
+}