summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 04:26:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 04:26:23 +0100
commit9e8f96c1b33dc01bc5dfbed0cfb2702bb299f1e0 (patch)
tree935774930075230b45a40e5c8da1e0199bf277a5 /dev-python/pytest-mock
parent796e724b5ace96ff70d918765662edf62f1d8c85 (diff)
gentoo auto-resync : 10:07:2023 - 04:26:23
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.10.0.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index de7dab60742f..a8849dc8acb4 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-mock-3.10.0.tar.gz 28384 BLAKE2B 2f51f8be34094054b8f7864eb083dde00800adb73af668444d21c95d8f159594bed0f68694e7ffb0e24da402a4865f37c07d85622ad00f130ccdb4e3d189bf9a SHA512 2ad6866d581a2999899e399ef5516d478a6172f52923f03703e3e3708229fb3b1178c91225b5cc90734c96abcb48fea517b11e0fc193da6fb592295395c14cd3
DIST pytest-mock-3.11.1.tar.gz 31251 BLAKE2B 26655487947d614483f082f17c9f3a9fc2688c016d07c6d4c4e34c369f87f3d914cf82d966a655e1eee501088d27d711f1b65f0c777678254dcfffa5c8c7585f SHA512 f52147498657d35f4616ea788b500a68ffcf1c2c066047fb973308b54e11bd7fe5a3961115bab99ae6858000ebb68b35cc489e81221a0bd26afae8426092ff6b
-EBUILD pytest-mock-3.10.0.ebuild 1405 BLAKE2B ac69d8f543c28b210973247745f49d9625f090968cdc0fd95cc0d8f76b2022ee88821e7e2db855800286a81636ac030ba6b9e37a1387c46e3decefb4952c8e5c SHA512 e5e84e317d86e6437e039a3e495c563b504ec93c1739622d8ca292969c6a0942e036fc1f40d6cfdadfe4c5236f959230a032d98bb6e6f445fe44796166045185
EBUILD pytest-mock-3.11.1.ebuild 1235 BLAKE2B 86631d6db534c3f1387249cab08f14907b3bde25b80c12569d016cb56f3154db7b214f5bd95f88f4af15d82cb29c9ae36cb6c2d57ac4bfdbb8e36a0bb2c93496 SHA512 e467081ebfc9673a5dcf9ccfd9f1a96a8b5df6f82a7e8499c980376c5e2b781f8398877068dc97f00da2387185756bf2ab1aaeea3a979545abb512c5001fb263
MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
deleted file mode 100644
index a72e71fb4369..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # obsolete, upst. e2016928db1147a2a46de6ee9fa878ca0e9d8fc8
- sed -i -e '/import py\.code/d' tests/test_pytest_mock.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}