summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-3.6.1.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.6.1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
index 8f048a9f8998..7e9b2eb105f5 100644
--- a/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
@@ -12,21 +12,25 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~x64-macos"
RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+src_prepare() {
+ sed -e 's/runpytest_subprocess(/&"-p","no:xprocess",/' -i tests/test_pytest_mock.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
- local deselect=()
if has_version dev-python/mock; then
- deselect+=(
+ local EPYTEST_DESELECT=(
tests/test_pytest_mock.py::test_standalone_mock
)
fi
distutils_install_for_testing
- epytest --assert=plain ${deselect[@]/#/--deselect }
+ epytest --assert=plain
}