summaryrefslogtreecommitdiff
path: root/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild')
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild b/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
new file mode 100644
index 000000000000..30042a6adbdf
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="https://github.com/davehunt/pytest-metadata/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test || die
+}