summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-localserver
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest4
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild4
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild35
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 644acd4c3701..62ec608f7575 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,3 +1,5 @@
DIST pytest-localserver-0.5.1.tar.gz 19341 BLAKE2B 759a90552b6f950579088a7c41448ad0f000aab980c56361d0e1a40d98a00ee234bf542a6309eb096602536da3fa819b7227a962d0592a801131a019f1617cdc SHA512 dad8b21020cf2f08ad03398b82bad7b47e553a9c6b489b94186bdc61c22f57e7151f8dbeab38ef42d03658104ec42920ec363288a1bdbea34dab6aee1da03c48
-EBUILD pytest-localserver-0.5.1.ebuild 695 BLAKE2B 3bc21eb09890567be4114e111440c538f6508379e12460fc9dc3dc09382af293aa59a5e985374a1ed79c430dc2649d34cdb11b49397931b96fcd007df8a7b215 SHA512 48af4bde5e90744ea75dc271a39f0b46fb251c23995a362c7982f97200941bf71c4fa50539c643169aa4470e5ab510f7ead0e2aaebfffbfac65ea1bf95d4173c
+DIST pytest-localserver-0.6.0.tar.gz 182346 BLAKE2B b8f56c6db3bc9c260c747cdf707aac0de22152111d3a8f9c0ea8adb8e5e556edf4a1ffa0d4fd517bf95428c69ebc0c1629a103c3b8f44a57b939f696cb9240cd SHA512 149796393af260fa5d69560852e9d11b569515b8486859302af2ed369a93bbb7cad11f54210851bd4030d8f7f5936a0306fe9599bc8477bdfc61d3d0a83cb205
+EBUILD pytest-localserver-0.5.1.ebuild 701 BLAKE2B e3287dc598c4b1866ebe74c80dc2f5f4fd8f49b1d1b18802cdaf9e8927ab7ce2d5920fd9a44cca74116e8b0fbc3382c89b6498ab26a88edbb9036f691a138879 SHA512 f5af0f2eaef0d095d301ff67bafd2661a0e6ae36fc4e20faa11adfe2e43f77bbadb27abc1bbcc7a304a85fd4bbd4c5a29639acbc04b4490221f55a5c5e56919a
+EBUILD pytest-localserver-0.6.0.ebuild 832 BLAKE2B a6b3ec2b596e2f222dfcad293373f54cbfea541d7aea34d85bd955deeadd2ae9c10c5f81a9e2f06726514e28cdb999383c0995bda9477a8350be0890cc9df641 SHA512 8a84c5b1c101785e8d9965f58b29505b71c8efba639d1030e796d52ebca5344421e686d6d10dbedad71a3a5fd9e7d3fe0ec177910e7449887510c29d8348afee
MISC metadata.xml 346 BLAKE2B 00f1243b0ef08f63d41fd211743230b93c976b52c5048bcdb2b5317610541a088ca13302e9c66e6a1a03156f071c5808d6960ccb1bfcf1349ba727f7ea608c25 SHA512 515a24e3a2fe049ad130ed44c1d42fb92ddf2f1bb4e512f8fce7e63b18af8529ae8790ca0dfc9b93589940c00fce192f1b16063936be26358e0e827afd359148
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild
index 31b9d6f5b1fa..96b9ecf2c9f2 100644
--- a/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild
+++ b/dev-python/pytest-localserver/pytest-localserver-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
BDEPEND="
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild
new file mode 100644
index 000000000000..809e2e45c873
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)