summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localftpserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
commit9d4810f84de876ec9d0ae03d0d44224500b41188 (patch)
tree1ca0866afdc949e405d20635d3d7f2115abb9ace /dev-python/pytest-localftpserver
parent075fd1f8cabc5879c6eb42127fb84c3058677fde (diff)
gentoo auto-resync : 19:05:2024 - 00:01:59
Diffstat (limited to 'dev-python/pytest-localftpserver')
-rw-r--r--dev-python/pytest-localftpserver/Manifest2
-rw-r--r--dev-python/pytest-localftpserver/pytest-localftpserver-1.3.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-localftpserver/Manifest b/dev-python/pytest-localftpserver/Manifest
index 6721daa95c1b..ea9f53cc6c18 100644
--- a/dev-python/pytest-localftpserver/Manifest
+++ b/dev-python/pytest-localftpserver/Manifest
@@ -1,3 +1,5 @@
DIST pytest_localftpserver-1.2.0.tar.gz 48817 BLAKE2B ccccd0b2cdc2596fa12c8f082fd2fa3847541b731367abfccb7a57d3408d74c1637bfc644bb80482d9a1a25072d94b1f663b8ad8c0ad51c2d9dac65156a80638 SHA512 19e300c4ebb1d89ebfa4dce04296b8962014a139f82a409f6d46f748f653cfd1f4192a7fb65987015b2bf7237682507c4d6e42dab816c275ba7f8a302eb9a3e9
+DIST pytest_localftpserver-1.3.1.tar.gz 48894 BLAKE2B a90003e61eeeefaa0d0fab7e7e44d2c87c02fe976bbe75b9596c9a79c969636370f776b41a3cbe45ed949cffef40b176510dad8aefa7be115ca7f1c704634b2c SHA512 605ef5b96c046f9b949d62800bb37a74b4807718a1591ff9374526b0c990280ed32470c79943097afe101e2c8d7691c49510a0cb0a7170f470f3cef226879824
EBUILD pytest-localftpserver-1.2.0.ebuild 887 BLAKE2B e9ce11ed4a27ecea98869f1b295a32cd87255bc8bae00564a4e76ebcd56e07b4129848edc7c0839cc75f6c53db28c8a9cc71cb0db5c815651ede0f3cade85690 SHA512 93b0642a6715e2cb1e571f276b940e2ca7d91d86f67d27f95281d578ecfbce14e3c0fb7b44cfda2145634569d330afbedf6c2222e1cfc66f3a1232269c3e1290
+EBUILD pytest-localftpserver-1.3.1.ebuild 893 BLAKE2B 7b2bdab6e13ddba274e96eaefe1be525cf1270be73ed0d86c31fb1bbf06b50d84d190300a11eee885e4ee160ac4a12bebab77d91a5ad8cc87d4e712ad56da6f3 SHA512 91fdbd4433261055a947b722d70db1165584197245dde6be89d2c29610c8fcb3445d056059fc7ffe3c056f4ca32d6a37d14c92d6c0688dd5dc9f360e4e514660
MISC metadata.xml 569 BLAKE2B 5a2afdbd9c95515e83ac146f95c1c1da36e556402c625151fb52bf067e58d4178111e8fb0457113cc292b0f480ccb9b1d4026f9bcb212db57711b4c08e3db658 SHA512 cdcf50653ca1020b258d9c38e524d6a27c9e287cdb286f36d568dd2fc1b07dad241df07d0fcc2466d341d11d3d0ade5ddb033b026eba744500cc2931da44064d
diff --git a/dev-python/pytest-localftpserver/pytest-localftpserver-1.3.1.ebuild b/dev-python/pytest-localftpserver/pytest-localftpserver-1.3.1.ebuild
new file mode 100644
index 000000000000..eea2b77209bd
--- /dev/null
+++ b/dev-python/pytest-localftpserver/pytest-localftpserver-1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A PyTest plugin which provides an FTP fixture for your tests"
+HOMEPAGE="
+ https://github.com/oz123/pytest-localftpserver/
+ https://pypi.org/project/pytest-localftpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+EPYTEST_IGNORE=(
+ # These tests require python wget module
+ tests/test_pytest_localftpserver.py
+ tests/test_pytest_localftpserver_TLS.py
+ tests/test_pytest_localftpserver_with_env_var.py
+)
+
+distutils_enable_tests pytest