summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localftpserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-localftpserver
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-localftpserver')
-rw-r--r--dev-python/pytest-localftpserver/Manifest4
-rw-r--r--dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild (renamed from dev-python/pytest-localftpserver/pytest-localftpserver-1.1.2.ebuild)22
2 files changed, 15 insertions, 11 deletions
diff --git a/dev-python/pytest-localftpserver/Manifest b/dev-python/pytest-localftpserver/Manifest
index 1356bd59b9f6..0be800529293 100644
--- a/dev-python/pytest-localftpserver/Manifest
+++ b/dev-python/pytest-localftpserver/Manifest
@@ -1,3 +1,3 @@
-DIST pytest_localftpserver-1.1.2.tar.gz 41275 BLAKE2B ddab430541208ea7e30b7091f0e5ed1ff347c4f289c79e1bf93e7fc56ac3d9076065afefb383e8e394cf702ce906747c7450acc0423df73cba5762cac01efec2 SHA512 44dfb4e680f82d6156212a06e320d437c5aa947b149177bb05a612473f882e0d2e8ff02751d0f79d56596cada82a299c9266b5849220687cea1028df7ca1bb00
-EBUILD pytest-localftpserver-1.1.2.ebuild 622 BLAKE2B ba6c3e8a0cb91820caa2fbf4f67813526c4169d0e1e60c3de39170702978fe27261f819db005dbf9609ee185191b85a914e49523613a3e61ee901b50265fea22 SHA512 90113f93c94de2ac8661059b07445fab8d9195ef6210438ea38dfa24d703fcfaf9365d67340d4b39086d87aa591560fd248c98a4bef44e0c6f768b32d40f08d7
+DIST pytest_localftpserver-1.1.3.tar.gz 44510 BLAKE2B 98085adc5dd31bb6556ea1f31c6342e8453a07c24658baf5fe94e91a001e9b88c5f6ef01a3a8419bd7b1bd3eb053ef52788c80926c5984b523d9f575224ff6ec SHA512 8058f7c6853acf709fdf4e0ce169af4281e2236a615261c0e148965dc1899af78b558ae5231600a106c538c1790ad886bea80ba7ebf278c70b6d553e58c0202b
+EBUILD pytest-localftpserver-1.1.3.ebuild 821 BLAKE2B 4c258f31b34e2ff29d4f284783871e7485267815b3d23bc557701be7a9ef0b2e4be9db9f74f6c2402da2f24beec173e6f2a49f12ffc59cdf23f35c3c28f0818e SHA512 77a1c02e55dd513eb1167e361e65504622a0c04ef0161b98bb46e4cc4de67814a46f6554716c7c7aa9c08da742443b621ebbd8265f42bbbd70a93e22ae8d3f95
MISC metadata.xml 569 BLAKE2B 5a2afdbd9c95515e83ac146f95c1c1da36e556402c625151fb52bf067e58d4178111e8fb0457113cc292b0f480ccb9b1d4026f9bcb212db57711b4c08e3db658 SHA512 cdcf50653ca1020b258d9c38e524d6a27c9e287cdb286f36d568dd2fc1b07dad241df07d0fcc2466d341d11d3d0ade5ddb033b026eba744500cc2931da44064d
diff --git a/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.2.ebuild b/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild
index 4706d32e6255..e826b9bbbf46 100644
--- a/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.2.ebuild
+++ b/dev-python/pytest-localftpserver/pytest-localftpserver-1.1.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PN="${PN/-/_}"
@@ -13,16 +13,20 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A PyTest plugin which provides an FTP fixture for your tests"
HOMEPAGE="https://pypi.org/project/pytest-localserver/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-# Tests require python wget module, but not in Portage
-RESTRICT="test"
-
RDEPEND="dev-python/pyftpdlib[${PYTHON_USEDEP}]"
-
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
+EPYTEST_IGNORE=(
+ # These tests require python wget module, but not in Portage
+ tests/test_pytest_localftpserver.py
+ tests/test_pytest_localftpserver_TLS.py
+ tests/test_pytest_localftpserver_with_env_var.py
+)
+
+distutils_enable_tests pytest