summaryrefslogtreecommitdiff
path: root/dev-python/pytest-lazy-fixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-20 11:40:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-20 11:40:01 +0000
commitd6ecedbb65041ed35010095376e87dd7de4270c5 (patch)
treef00964f121a5ec52d2f3d1fd00a8f3eb52f9c756 /dev-python/pytest-lazy-fixtures
parent89a009d7439343e207e8c7e4df1a28adecafeffe (diff)
gentoo auto-resync : 20:02:2024 - 11:40:01
Diffstat (limited to 'dev-python/pytest-lazy-fixtures')
-rw-r--r--dev-python/pytest-lazy-fixtures/Manifest3
-rw-r--r--dev-python/pytest-lazy-fixtures/metadata.xml12
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixtures/Manifest b/dev-python/pytest-lazy-fixtures/Manifest
new file mode 100644
index 000000000000..9d8f922b98c1
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-lazy-fixtures-1.0.5.gh.tar.gz 20107 BLAKE2B 543f1a2c9a134fc238c686286b81367c3d6ad21b0bb4b171e2c00f1b961a7813a6c6b141dd265a360c40da7d6e1fd0d48c5ea8d8fc3804a09a39447c0c1c7970 SHA512 c84bce864c5e482c5115ba4c1c8caec9e97a85af4fc839a9fa3a472306d12e1c4564cf4323545be2c6af52c1dc22c24a3e25eae434696953f9efd5d822663601
+EBUILD pytest-lazy-fixtures-1.0.5.ebuild 705 BLAKE2B 9faac3e5ee1531cde4903489eaebbe0ff8ae157f5eda88089dbbf3b9b252df05d14b48dbb7049bd13152de3400bb827484f28c5b6508f36b6b3bed2a009c9a57 SHA512 99684e5cc86d6ed57e1f24b086aad43919badf075b8ee35f67ddd907215c2d0e5faa70dd8855dbf7a6f6065a3df2fcb5f07ebcfdb6a31b6e024b9d22c500d823
+MISC metadata.xml 397 BLAKE2B 99b31408b673a22388daa05cfe76d1f44e94e684dc14717d2a403e1734b703cabc100d687e888bd7c36df54fb49128b849ad6817bdcf01f1c36e497c32106427 SHA512 f5f34da24f19be54a81e06235102712399cd253b2981e7d01aedf730891cdf55cbaf816d99a0ef09b108475db79f05d940cd8b0487f5b9fc0c399fe29ba7ae95
diff --git a/dev-python/pytest-lazy-fixtures/metadata.xml b/dev-python/pytest-lazy-fixtures/metadata.xml
new file mode 100644
index 000000000000..e66300e8bbd2
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">dev-petrov/pytest-lazy-fixtures</remote-id>
+ <remote-id type="pypi">pytest-lazy-fixtures</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild
new file mode 100644
index 000000000000..dcfd7e162c09
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
+HOMEPAGE="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/
+ https://pypi.org/project/pytest-lazy-fixtures/
+"
+SRC_URI="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}