summaryrefslogtreecommitdiff
path: root/dev-python/pytest-lazy-fixture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
commit8455eae17683fbd2c785ca4b8443581622f388c7 (patch)
tree51bb7aac8b41b8f6e692f9e5b4e65001315b43fd /dev-python/pytest-lazy-fixture
parentb2f1788f6f0365b76f55f257b2d170c1e68a8640 (diff)
gentoo auto-resync : 29:01:2024 - 18:57:21
Diffstat (limited to 'dev-python/pytest-lazy-fixture')
-rw-r--r--dev-python/pytest-lazy-fixture/Manifest2
-rw-r--r--dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild (renamed from dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild)14
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/pytest-lazy-fixture/Manifest b/dev-python/pytest-lazy-fixture/Manifest
index bfa74cfef6b0..cdf0e1125319 100644
--- a/dev-python/pytest-lazy-fixture/Manifest
+++ b/dev-python/pytest-lazy-fixture/Manifest
@@ -1,3 +1,3 @@
DIST pytest-lazy-fixture-0.6.3.tar.gz 7878 BLAKE2B f3a034678f590090a453b44b9fea938ced040c80922f139f3321ec20db856be219d039c7f4199ef67af79b5008d37425b5c08a0edaf71fdd7c8f248702acf488 SHA512 3281edc516f21f23104d7fc188b5c9aecf364f55109dab52865cbfef4a540727eb2bd42fb9806a7e8be728b249bc7a224ffdbab96473f043bef9a7aea1e4baa8
-EBUILD pytest-lazy-fixture-0.6.3.ebuild 540 BLAKE2B 35e1a05530833f3366ddb45b330a0d474c5fe4c9eebf958c15155128a41890df9ebf36c0f3a7104538bb369e075fa90ea8107cfc386744094f697ade5af11a1d SHA512 4a3faedf384943dc5cebb21bf1e3ffe1309f6eaa63a70f0dfdf6bfd26eb5f8e5b3ea183dba2563bcb81f254514aba1566edb72985402a3edb235751856c9ef3b
+EBUILD pytest-lazy-fixture-0.6.3-r1.ebuild 598 BLAKE2B ebe4ad9d86d6396ec4c24f4334c1f588e74609131bbb22ceeff5f97565e5a1b4a82845c55be6e07a2c345045254d63118ab7f94bfc9b90596c4a96610656b064 SHA512 ad7bc20baa467985492b7505608713661b20050360846543687e0f3dc82936b1cf4102ddfc71cd0ef454759dbca8fb366a58bef0bfde056a83637a70aa1e7606
MISC metadata.xml 413 BLAKE2B 12c78c7219d94bb10ab01fa41375b079240b89e2a9749c712859f279b17250a324bba3eeef519e0008130e9a2d9a859a09dfe7e7f618dfed41ea6fd7b93bb58a SHA512 96aafce95f7f50725348911c54f1b0876f413caf0c41fddbe55caf57495e799ebc8884790a22c3b7c2d89b2dc9354c592a1ed8a6852b9a51b4a80c4f124d57ac
diff --git a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
index 7088080bf410..500904a50a46 100644
--- a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild
+++ b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
@@ -1,20 +1,26 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
inherit distutils-r1 pypi
DESCRIPTION="It helps to use fixtures in pytest.mark.parametrize"
-HOMEPAGE="https://github.com/tvorog/pytest-lazy-fixture"
+HOMEPAGE="
+ https://github.com/tvorog/pytest-lazy-fixture/
+ https://pypi.org/project/pytest-lazy-fixture/
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc64 ~riscv ~s390 sparc x86"
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+RDEPEND="
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest