summaryrefslogtreecommitdiff
path: root/dev-python/pytest-lazy-fixture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/pytest-lazy-fixture
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/pytest-lazy-fixture')
-rw-r--r--dev-python/pytest-lazy-fixture/Manifest3
-rw-r--r--dev-python/pytest-lazy-fixture/metadata.xml12
-rw-r--r--dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixture/Manifest b/dev-python/pytest-lazy-fixture/Manifest
new file mode 100644
index 000000000000..a72e16442ba5
--- /dev/null
+++ b/dev-python/pytest-lazy-fixture/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-lazy-fixture-0.6.2.tar.gz 7737 BLAKE2B 5257a19314a1c9bd159222a170e96db12e5f7b99d2bf83fd2db94acda9726f10997a81239763d8b0d5f2b9f2be6b74acf350d996cff09cf413d3a8ac76e2d90c SHA512 d8d159e936937f4b9364e9be7fcb8228497849a1ef342878ecc8471cd3b06782d2c6029365fd1e02f1ff89eb048ccae625b8697dc5048b4dd8fa61d839ca3f36
+EBUILD pytest-lazy-fixture-0.6.2.ebuild 538 BLAKE2B aa39fd100917d7524f451e7b20009b1e65a319e0333c4a23b516b1ddadc03e2ff5a8d77d8d1af1f0a35de3fbc9919333dcac1d29b43671e97161b29772b62ed2 SHA512 b85a5d83d58ea87c938c49a54477a397befcfcbdd8abf10852412d25a37a3993cef2ccf31c096ddfdbe8f8a12ad5f575b7480c9deb223ca958884184d62812a2
+MISC metadata.xml 387 BLAKE2B 6fd0bd59ab8f2f63eb2c2e157e043cbd22b26a4c9e883fa9f78a01b0b43488d1873b4ac0bd69d8c2d24f21fc938ce703942c1bd0a1766db4bc993c91d9a3eaa5 SHA512 207f63c3317663c51ca3e6abdbeba25a08a2b8956d8d80812574dd522630e4e1b5ead010c7cf933bb02e356d59bcd9ec8ee39d1eb7af823b43a194af2d953646
diff --git a/dev-python/pytest-lazy-fixture/metadata.xml b/dev-python/pytest-lazy-fixture/metadata.xml
new file mode 100644
index 000000000000..443a7275aaa5
--- /dev/null
+++ b/dev-python/pytest-lazy-fixture/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild
new file mode 100644
index 000000000000..de6b1f46fd90
--- /dev/null
+++ b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="It helps to use fixtures in pytest.mark.parametrize"
+HOMEPAGE="https://github.com/tvorog/pytest-lazy-fixture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest