summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-21 19:57:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-21 19:57:51 +0000
commitfe3d938433735c9b681b7e72296a5ae70fd2a7e9 (patch)
tree7ec2937cecc4be47ff9ab102db046946216609ea /dev-python/pytest-httpx
parentd8e7aaf1b90b28ec354e7854abea07d53644e754 (diff)
gentoo auto-resync : 21:12:2023 - 19:57:50
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index ebae9feeedfb..76aef8ab19da 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpx-0.27.0.tar.gz 33905 BLAKE2B 352812df060f878044a628dee62ab36f15d17080afc0367b6331c2e5e13600eefff7a3668f4a9364d437394ad8f8354f41619ec4f6b8bc5ac14b1cd652357802 SHA512 e2834313f507d02b9df96a47f8be6f46b451972e88ed9c9bfcb8bdb92545cc44064b11a1160a5d9d900381181918611d5d5a9efaf60f4e491f33182e9bd884dd
+DIST pytest_httpx-0.28.0.tar.gz 34065 BLAKE2B 13b52ba38a6e98f0d9aa10109b2d476feedfef516492b4cbe3f2cc91d1b1809934409e0e696021e1b2d5e3668cf3493834f44cb11940bac73f64949a73401308 SHA512 5dae77c04e1d801ba63a487d91e2d80a94e0626673749453ce0d273bbe876967d73789dc7811f1e96ad7366de2a00a5cee1a512398693b41e7cbc2424cb0c44f
EBUILD pytest-httpx-0.27.0.ebuild 643 BLAKE2B c94e43f74f465175b5f7781f8c826b284126479c92b25c5fdf0d51f6ecfd9cda204871cb3ee2f2dd644653ae209b1586385072a27c3802602a6f2acf4a3d8af6 SHA512 34bdd52f3ecc4d2097f33cf2b6ee1ee0cbb97fad86ad23d8e0d83ee206bad6f0735d826725bc38e9363fb057dafe32482312b82966f012fa1edc34dfc730d139
+EBUILD pytest-httpx-0.28.0.ebuild 646 BLAKE2B dd9744d51dd316fe19913f72d334857044fd09801db909bb92ff47241751c5729ccbae6a41722b66b0174266968f37bc36ee2cde5462d8fd2d7841c34c971466 SHA512 62f55a3c336e1ca1005353ae62aa5f939562ba0cc5b7fd256b0833484b146be9a3ebe449b4f21cae41ac631453579b4a8044f9e6a424236c9039a3d357c813c1
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild
new file mode 100644
index 000000000000..0319210f3619
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.26*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest