summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 10:40:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 10:40:56 +0100
commitfc1125ea4b3373e327ba0e157daa1d7e8aee15f9 (patch)
tree44c9694d007e95c09700bf72177701759333a717 /dev-python/pytest-httpx
parent5d5e56d92268c2b9b6ccc38eeaa3516ce9b1e8fd (diff)
gentoo auto-resync : 12:09:2023 - 10:40:55
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index b1204c3607f5..d2ff45e132a6 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,5 +1,7 @@
DIST pytest_httpx-0.23.1.tar.gz 29462 BLAKE2B aaccef0152a4b7a6340ef322135dcea366df04f349e5d0b4ee9f02a9995485306da4c7854ef4235543b0dcb0228e2f5957790b2b58a0f41bb739849bfdf26cbc SHA512 4490c716c341d782ebf02c29475b7618c0717bbaa736b0a0eefee8a7c8498d3474dd28d487469fe5806ba0018a07b538d2f583406f561c451de6f8a688d57901
DIST pytest_httpx-0.24.0.tar.gz 31665 BLAKE2B 2b9ec1c97635179b10052b32a5e1245ec44882f485e427cad7e278913c62b300f0a2e6637254469be15c68905e8b3fe2a34923e583f780b08e14433d625382f2 SHA512 b84b7fa80bcc80c8e1ef7324bd3e559d020b993bafa8835ea40bd33d6fc97208e391d86807ee2c7959eda01f615e1001876f346e67fb9dc645ad00a1feea9e64
+DIST pytest_httpx-0.25.0.tar.gz 31681 BLAKE2B 6ebeda25278ef2f80705d8cafdf3acb745feb4594aa966efc2c4bd258ccee312a3a11a89e0dff2ae789bc1dbc5dce3b8ccd74b23144ba7fa2ff9fef8ac13557f SHA512 a2513b5d75f281fae12e8e06151eaa52e35defa67aeca1f5ea146ecf3735897c0d440d11af8dbfb31a2be8ff9ea5d86962060c78b8d3ea1d83c0c870611a2a5f
EBUILD pytest-httpx-0.23.1.ebuild 637 BLAKE2B 1e9ac99af58c195eb16f046d8abb13eb67c86cb8d0435edbeb1acee1afa837b527bb2724d02ea61fb8a01edf876d4344ef443fab681157631b1c4cefdc2bcc3f SHA512 aa4f4460dec737afd12c3a8c84a3f9d701aaf93f755734ea611d9bf3a40f34274e828ef9dd9eaff08fc82fa52b9a5f1271c257caba11abde683231a02433b2af
EBUILD pytest-httpx-0.24.0.ebuild 639 BLAKE2B a86a8392f445c6ac693fb72d12e3fc81897afc3bdf47ef92099c4288c9c5a146f7e8a308f313e460937281b808d31bad49e0097fc710bdc41e0fc88dfd3ed048 SHA512 9ccfcb97f463a41baf481d653787a72236fe57075dea7fa2ad125e58637ee5ae8568b76fa1a36eaa6fb843346af06dda5fcc88f32eecba07ce2106f13fba5a79
+EBUILD pytest-httpx-0.25.0.ebuild 639 BLAKE2B cf1275d88e08b1b1045377fc94ac2bdcaf2e8219515d00a418cb22365f1e3458154863e7a901d2ec8810549f3f9892899ff99f7fb49bc8a28fc79892e40d95d3 SHA512 7441b8caab86f5f9623f40cb252a06a50565978fbc7d23b50df1caea2035c48653c676ab772971cc4f8094537f786370c58500acea6901514487b589b8eb8e4b
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild
new file mode 100644
index 000000000000..1926979c400c
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.25.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.25*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest