summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /dev-python/pytest-httpx
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 3a5a82a14d3d..d74326258d1e 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,5 +1,7 @@
DIST pytest-httpx-0.21.0.gh.tar.gz 23123 BLAKE2B a9a1bc9effc557829071f13cec76aa1d164ae7040b685390c92f33c644c804448eba1ad3e841abdb667a2c0289abd64f5d3633779bd8b0355a1c03d390d94bd5 SHA512 6be6fb39ad1ef233ce9be7cf510422754b6c97a1b565d49224e82cbe4218ee24051b6c5865215ed575f200446dfe8dd1470908467c67077c51a4f5412b113c2a
DIST pytest-httpx-0.21.1.gh.tar.gz 23997 BLAKE2B feba932cd8a4e7e36cbf98a5c07f8e3264c9f95568568dd4ec4b882a509a4feafd740d3c25a547b7ea28f7e5450083a5f5f7afde0b19bfe46f7999b01565fbe3 SHA512 22cd471996202c78c3d3b433f8ed525e0282df431f0923cfbce42fd543b56a2af20723062773a1a3e3f406a0ce6aa6eed27faaa76731472a903cdad6fb13f771
+DIST pytest-httpx-0.21.2.gh.tar.gz 24311 BLAKE2B ae1ce7ada3977c3bd68f31b5e20e93ac32f2459359bcff30d1ccf358b07ce269f38acb06b46211ddaed1085a9cf78fcefb921a978a5ca4f6c84fe25b602a3a25 SHA512 d8a9d1381a7c1bb1f907effce48bcd4cad29b2eb135e5d18e7ba3025ba2f18d97c7914f0cfb835416dfa608c59ed51db653b0366d407cfbb82fc520808f3792e
EBUILD pytest-httpx-0.21.0.ebuild 769 BLAKE2B 97cd781f719ab8478c394d961ab45506ac8d30a374706bae1cb0fc4e0f2b8d2f62f78deb5b283da7e66db18c7aff58d6545aa8d366f752ad1e21f19cbca28643 SHA512 0c7647d481c7bb97e95eafce830c03cfb02b596c23548c33d0baf6d69413e4d1db8ad9d4610cc706f8c6fe58818b36b13f436f71d62b284df04e1b899b8df981
EBUILD pytest-httpx-0.21.1.ebuild 771 BLAKE2B 2b4214c2c7375e215e9f070227840486b98a6a045af2dabd1cec997e70777e335efa00f9bd367b419da73cc0929e37aad5dcaac2db0e681ad732f4353176f748 SHA512 ea9698c8ad8743e1ebf41ea255e19ebab0dc3a828a8bced8885b7d695b2f6288e1fd0b004c15be26f3b0d8514799c5151f52642fd3e6d590ee884e7cb2d6d70a
+EBUILD pytest-httpx-0.21.2.ebuild 771 BLAKE2B 2b4214c2c7375e215e9f070227840486b98a6a045af2dabd1cec997e70777e335efa00f9bd367b419da73cc0929e37aad5dcaac2db0e681ad732f4353176f748 SHA512 ea9698c8ad8743e1ebf41ea255e19ebab0dc3a828a8bced8885b7d695b2f6288e1fd0b004c15be26f3b0d8514799c5151f52642fd3e6d590ee884e7cb2d6d70a
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.2.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.2.ebuild
new file mode 100644
index 000000000000..779e7bf2b179
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.21.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest