summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 10:30:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 10:30:49 +0000
commitcd8b6c60f3cbb06647bf3d03fb2ac29ccfc31c8f (patch)
tree2e3b9d43dc19a31fee73728c8a91e2e02e6b243e /dev-python/pytest-httpx
parent62ce4dfbf01c603a668dabde87ccc5b4ca4069af (diff)
gentoo auto-resync : 14:11:2023 - 10:30:49
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 6298e6e57d7c..59f5d052b0ee 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpx-0.26.0.tar.gz 33490 BLAKE2B 27c267374a575aff2ecbaec4855b733318568d73368a103f93606cc8833be4d4e664418e2f4b67df2d39a8830dd32d75d3a00656e58824b6beb18c4cc0bf3a14 SHA512 b671984714e8958361a773ef5e3f7430736b01556c6af58aac4ca740a679b5c2e316e2d041e1594cc16e7e13cee9692f57dcbbf374ca15924685250f73cc7853
+DIST pytest_httpx-0.27.0.tar.gz 33905 BLAKE2B 352812df060f878044a628dee62ab36f15d17080afc0367b6331c2e5e13600eefff7a3668f4a9364d437394ad8f8354f41619ec4f6b8bc5ac14b1cd652357802 SHA512 e2834313f507d02b9df96a47f8be6f46b451972e88ed9c9bfcb8bdb92545cc44064b11a1160a5d9d900381181918611d5d5a9efaf60f4e491f33182e9bd884dd
EBUILD pytest-httpx-0.26.0.ebuild 637 BLAKE2B 25c6982a9cee6f23d44d1642b7d1f47f541f3acee767c79474830483400f45db811d780cf2c3f1faa0c65ee1d1bf2a3c0a6422d191393f908c750ddc38f85bb7 SHA512 a4612b0d8432658348d3d91afcda20105a922b75ef16cef68aaad26adc942a0a49323d234f293312febd33b585d91e5122f88af49298a4df22777e7d42b0539b
+EBUILD pytest-httpx-0.27.0.ebuild 639 BLAKE2B cf1275d88e08b1b1045377fc94ac2bdcaf2e8219515d00a418cb22365f1e3458154863e7a901d2ec8810549f3f9892899ff99f7fb49bc8a28fc79892e40d95d3 SHA512 7441b8caab86f5f9623f40cb252a06a50565978fbc7d23b50df1caea2035c48653c676ab772971cc4f8094537f786370c58500acea6901514487b589b8eb8e4b
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild
new file mode 100644
index 000000000000..1926979c400c
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.27.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.25*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest