summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 10:49:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 10:49:51 +0100
commita308b9d4bf7fb28a64aec9444316a00068c164f6 (patch)
treef3b3c687c12c2439e961bb78cea4cbcd08d27edb /dev-python/pytest-httpx
parent567324b6954816e085ab34edc30e531d26aed9f0 (diff)
gentoo auto-resync : 02:08:2023 - 10:49:50
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index a8d6083a4652..eb30b45fc446 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest-httpx-0.22.0.gh.tar.gz 24409 BLAKE2B 9db6622e4997ddf0a70c1a0ef835b077640b3ce1d1c19792feda573577fac1ecfba16bcb7ecb8e4c1578b345764d8301aa121335a259dc91a4805173a549bea3 SHA512 fd89ce70113608195eb8fa8e3d7465d9d15b5a300e7c00f3c50417ba9b205081671fbda9591bdb16accb1973da00f5d0bede9e73a3351b0652080d4059c5f6d6
+DIST pytest_httpx-0.23.0.tar.gz 28994 BLAKE2B 909fb72d6172fc1a504f1e6ceaf8eb607a5f59fdafc424400567c7ac11ce6d135353be46cd669864b770b5b4dc0403d2c71b3618e733d124cfd86bb88cb76bc5 SHA512 c0ef087bbcc9e214bda19596c11ca38062c8cd14bb10bff36d9faab3ddf326813f30e70dce476b82a9dae72feac3127625920059fd6e64d8b06edf3004a549a6
EBUILD pytest-httpx-0.22.0.ebuild 858 BLAKE2B dd4e47959aab0f7ee9f87e0636bcffde2bd04e0a4d4524f9c4791519b32bc1d9fef0a8e80c7d128c3a26ad8f957526573a73199569e1cdb9f0eec2004ff6db65 SHA512 ad0ebbc2e8f8597da2976c75179763928e48419715384d1aab893e766776674057d4ecd27d0a1f6aed1b9b6333e42a01f147725687e326babcdbb994099ad065
+EBUILD pytest-httpx-0.23.0.ebuild 639 BLAKE2B a86a8392f445c6ac693fb72d12e3fc81897afc3bdf47ef92099c4288c9c5a146f7e8a308f313e460937281b808d31bad49e0097fc710bdc41e0fc88dfd3ed048 SHA512 9ccfcb97f463a41baf481d653787a72236fe57075dea7fa2ad125e58637ee5ae8568b76fa1a36eaa6fb843346af06dda5fcc88f32eecba07ce2106f13fba5a79
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild
new file mode 100644
index 000000000000..336dab68638d
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.23.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest