summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 10:23:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 10:23:18 +0100
commit9aa62a2a35904a08cbf2e884d3abd89d893daf91 (patch)
tree9f612bb8f368bfd5d14d84f9922b073302e85d30 /dev-python/pytest-httpx
parentb89f5897f4301157fb1a4af17e0c941703a2579c (diff)
gentoo auto-resync : 05:09:2023 - 10:23:17
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.24.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 499e6d66d2fa..b1204c3607f5 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpx-0.23.1.tar.gz 29462 BLAKE2B aaccef0152a4b7a6340ef322135dcea366df04f349e5d0b4ee9f02a9995485306da4c7854ef4235543b0dcb0228e2f5957790b2b58a0f41bb739849bfdf26cbc SHA512 4490c716c341d782ebf02c29475b7618c0717bbaa736b0a0eefee8a7c8498d3474dd28d487469fe5806ba0018a07b538d2f583406f561c451de6f8a688d57901
+DIST pytest_httpx-0.24.0.tar.gz 31665 BLAKE2B 2b9ec1c97635179b10052b32a5e1245ec44882f485e427cad7e278913c62b300f0a2e6637254469be15c68905e8b3fe2a34923e583f780b08e14433d625382f2 SHA512 b84b7fa80bcc80c8e1ef7324bd3e559d020b993bafa8835ea40bd33d6fc97208e391d86807ee2c7959eda01f615e1001876f346e67fb9dc645ad00a1feea9e64
EBUILD pytest-httpx-0.23.1.ebuild 637 BLAKE2B 1e9ac99af58c195eb16f046d8abb13eb67c86cb8d0435edbeb1acee1afa837b527bb2724d02ea61fb8a01edf876d4344ef443fab681157631b1c4cefdc2bcc3f SHA512 aa4f4460dec737afd12c3a8c84a3f9d701aaf93f755734ea611d9bf3a40f34274e828ef9dd9eaff08fc82fa52b9a5f1271c257caba11abde683231a02433b2af
+EBUILD pytest-httpx-0.24.0.ebuild 639 BLAKE2B a86a8392f445c6ac693fb72d12e3fc81897afc3bdf47ef92099c4288c9c5a146f7e8a308f313e460937281b808d31bad49e0097fc710bdc41e0fc88dfd3ed048 SHA512 9ccfcb97f463a41baf481d653787a72236fe57075dea7fa2ad125e58637ee5ae8568b76fa1a36eaa6fb843346af06dda5fcc88f32eecba07ce2106f13fba5a79
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.24.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.24.0.ebuild
new file mode 100644
index 000000000000..336dab68638d
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.24.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest