summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-20 03:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-20 03:02:59 +0000
commit8a5f3383bbc5f817d89554020a3600d06985bc4a (patch)
treec1f7e85e7de87c74b4c730fab5369051cef5cb32 /dev-python/pytest-httpx
parentf2e359c456b051f95efc92e21299d55a302e58ed (diff)
gentoo auto-resync : 20:11:2024 - 03:02:59
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 89bb6e53b366..f4b0a4ce5c0e 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpx-0.33.0.tar.gz 51708 BLAKE2B c4b4a5bc41c44b982dcfe81f09ec4b3ee1eeed9cdc52cea6889988692bfb312eb7c4105cdcd60fadbbf0602236e2e5baf3c1a448248189214c0ec77cde8a3ea4 SHA512 96e3b5e0264f61644ed22fc809f35d0b2b255aa2ba75a5bf33d165c35276f2b731689b70cfbab5b5c901b1be4ff59c4b21704f8b15453582a6095611380830c8
+DIST pytest_httpx-0.34.0.tar.gz 54108 BLAKE2B b2c761a993d5c15aa28ee4d2b29ed44764c9825a3b9a9a471eef534a4f040324d6c822bfd413090d86428591be60d9092541a77188d8ef84bd3e333a976647da SHA512 49ca01ddd16fb68213ec2178111c65fb3f47be6416b67ebe356a47f658140ee42e275e07e377c6740956d895a4b1a719c2cf12ad9cbabc339b20cca94b892ef0
EBUILD pytest-httpx-0.33.0.ebuild 732 BLAKE2B a3ad5fc22688cb84f7baa7bb374b2554232cd8cbd0bf771470d668b0eea9e7adfeb23842dfb33d97d92521ee747d43b03e859c88d63f9c83cddb942dd737e31f SHA512 0e5131898dc35a0beb5a146b34cdd0aca86731f720a73a0d913e529cdee635f924d0ba5c0ab27a6f3003ba142b1adc1f115ee0e1cb5f66196fa0a921019e6454
+EBUILD pytest-httpx-0.34.0.ebuild 735 BLAKE2B 4c9a72d110909e5659e45ec2d33019285936cfa8b2323a862af757e9eb9c50b0e6a170deb10a7a7187ea73b4fdfc48e87c522f7ecb136db09a0602a383d1c7ca SHA512 2138642a7f7a9e6888973790d07307a008f3985c108a0bf292b6c37b216a4d51dfd50a23d5ddeecd82bcf99bdf34130032299855bdc5d38b52e41d0dc24b5ef9
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild
new file mode 100644
index 000000000000..609a6666899b
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ =dev-python/pytest-8*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest