summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
commit73e3b099187df1c4f2df056e45f345a56d2535aa (patch)
tree42fef135111a0d9bb70b2843f3d9158875b891b0 /dev-python/pytest-httpx
parentb0c85b2635958d1aa7c9cee8dbf22ad871a280f1 (diff)
gentoo auto-resync : 30:01:2024 - 05:49:55
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.29.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 91c7c07e183e..8be187d774ad 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpx-0.28.0.tar.gz 34065 BLAKE2B 13b52ba38a6e98f0d9aa10109b2d476feedfef516492b4cbe3f2cc91d1b1809934409e0e696021e1b2d5e3668cf3493834f44cb11940bac73f64949a73401308 SHA512 5dae77c04e1d801ba63a487d91e2d80a94e0626673749453ce0d273bbe876967d73789dc7811f1e96ad7366de2a00a5cee1a512398693b41e7cbc2424cb0c44f
+DIST pytest_httpx-0.29.0.tar.gz 34103 BLAKE2B b8ee299ce17861732050f0059905193ee964ca375734584356b26a179979f2f967b69d134b8fc9c0fd4ae75172c404dc8e9ec27bb50e6bed58f8e7e76a4aa9e6 SHA512 ada6f5f419de3fbe835a5ce9fba9e5d368cbb01d1826d61cd4bb5a7f2941030d40afa17e582eca20743a546bf98699ecc2d8a0c640efa69b390dc32f2349bb13
EBUILD pytest-httpx-0.28.0.ebuild 643 BLAKE2B 45a67553511e54a82b1761173d7b65351fd1974d119384313b3d499c10911716982d35de7408e360ed982b482b127e14a8f337ec3b1d797b724d1837ce20c2a1 SHA512 98407072a46d9345bad39fce850d304b325c40f6fec7ff4e19f344df73cf715c6e089b8600c1007943d2cea82dbf93cef13f3aab3c27dd47cd9f75a7969b3a4e
+EBUILD pytest-httpx-0.29.0.ebuild 646 BLAKE2B b19c3cf72e6e03f69df44ebe3c15230f42537f2021b8703ac3f9dec09b29df3a62e6317b65d8171f8721ff313072a74b20dcb0dffabf3e75cead53b656e59481 SHA512 21428fe63af8427f15011dab62f12849c7c1504aae8fe2144f89dd024a819594b203894cadf4008cf35fb812e968280fb21a72a21fe0c4902a6c66544a5bd8d1
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.29.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.29.0.ebuild
new file mode 100644
index 000000000000..1a6d514d120e
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.29.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.26*[${PYTHON_USEDEP}]
+ <dev-python/pytest-9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest