summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/pytest-httpx
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 87cc3d38ada2..c888a456281b 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,5 +1,7 @@
DIST pytest-httpx-0.10.1.tar.gz 21117 BLAKE2B 372ecc8a132f28bf7016ed466c4f6974f51c3c2ab9decd68fd8e3c7a810030db9f169f5ab28662cfed006297ea200d3a157ba220f2156b44be03fbf49edc5415 SHA512 f306e57408924b653d3ab4dd28f266b066f202b98440b31769940bdab0be98d5c48817e22d68e2dcdf82426e26334242591d0ae630aa71812f81dd7866b81e0f
DIST pytest-httpx-0.11.0.tar.gz 21178 BLAKE2B c58c303868fd1b1926a58db28eeda3c5d74cd38f68aad3543cb0296f4dcac59d9fb983287b432219f70bd2003c2a0e32d85ed343b1c279d576ef100b129c7f25 SHA512 eb798d31c710ab50d3176c569aba8ae2131a17f415fe87830fc71aa941d638bdbda4296032a07fce98d9a43a57f250cea380f8c409660eb1f13862094b6fcbb6
+DIST pytest-httpx-0.12.0.tar.gz 21319 BLAKE2B 59c3678937a7756f13971e3f1f8d312b227f56339b4234ac8e5544f4370622bcff401f76f68c2ee042fdc64deae6a7a9dd05ca8a54b60b14bfb74b2d2d724de4 SHA512 b5866ab0123755020fad679d27d4d113132b2a79da85c52a334904d19aea90ddc71088a6e0f27110498da2731be664c525f3cab256d447a37d9a507f9a508b43
EBUILD pytest-httpx-0.10.1.ebuild 652 BLAKE2B 46e3a52a92fa0a41113b83ab484f788ffefab9b78b1131d4ac93a10cf66a434353a18f2190f654232c6dac93448c56fdb94497f61b45f06f0e1ff6fccf06ed9d SHA512 deb414435242646088536df2966488bc188596d953d8c53c6957cd92b2ac2250b7840747c6198fa1068ae05821a1495aa966ed1e564247d0a1a1530ff5c53fc9
EBUILD pytest-httpx-0.11.0.ebuild 652 BLAKE2B 874b81051af4bbb2aaae6f0b45db7b5ea0deca1c63b32eb903591598268ae3776fce86a0211bbb5307d5f904741c240d0c23ddfa9ebdad0427693b007d34fa28 SHA512 eb0530d3b446928dd6e6bde6a9a79c49307184f4bf3ca5b033db2f5bb37862867a72d48f16d33a2204fdcafb84ef9ff334739c7002d3c5497688eaf63b991360
+EBUILD pytest-httpx-0.12.0.ebuild 652 BLAKE2B a6600bd0ee18c71ebfaf847a81d32c1ff24bdbabcd76a12753425f1acbb2e4e36ce51038d078bbe2264393a3a8d89438182a11c48f5de39dab3b92ff174cfd91 SHA512 99450df18c6b3a93794b44f2ab7e3c1a113d6e798e03e0435ebac2a63b90d345c0df0fccba016b70e8948081cc2536be38ff16ed8fcfa53af33253cee349cbda
MISC metadata.xml 467 BLAKE2B d13bfcccc41321e84d9e912be5e6106c376d7dd5a8bc596e69e570713fb2d0dee3627e29dc9c35c6638322c7edd328a6f60e6af8dc967fad302508dcfded32be SHA512 a6b6cc298ccbbc4b11c0e91a4402f634ee0f69e5ee53e09648f842771b8d6f3fdebe5114b3f55623b75e6539a794b6b94956a6eaf4e7f91e28eb6d4bcbb5f770
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild
new file mode 100644
index 000000000000..49212ed89c34
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.18*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest