summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
commit374561aeaff53ce5a2836af934749923b4ea3763 (patch)
tree66880cb44879bf28002f361a4c862814df616b8f /dev-python/pytest-httpx
parentea0515fa73da4755b498bdb18bd7fd7a13e616cf (diff)
gentoo auto-resync : 20:01:2023 - 23:41:20
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index cb508efc41ad..7f9efc5eb2e5 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest-httpx-0.21.2.gh.tar.gz 24311 BLAKE2B ae1ce7ada3977c3bd68f31b5e20e93ac32f2459359bcff30d1ccf358b07ce269f38acb06b46211ddaed1085a9cf78fcefb921a978a5ca4f6c84fe25b602a3a25 SHA512 d8a9d1381a7c1bb1f907effce48bcd4cad29b2eb135e5d18e7ba3025ba2f18d97c7914f0cfb835416dfa608c59ed51db653b0366d407cfbb82fc520808f3792e
+DIST pytest-httpx-0.21.3.gh.tar.gz 24373 BLAKE2B 8efa85974128a0c9d78bbc23b7c9bca17e68ebb09dafd3b49e5a09df54bd2808ab6e7995ab407b78495ac12a80239d7397169c8de539ec559a8c7cf95239b495 SHA512 8c25a702b9c049354a0f0b232eefeae5ac0c47764af023c89aba6829309971a1d79a0dab3e4d6275a6bf0f32f3a8309c9559eb22c9b742a6576ecea37ff0d15d
EBUILD pytest-httpx-0.21.2.ebuild 774 BLAKE2B 7eff7358b4d922d9e06886de8776f87085171522b9c397454cbf7ea82ea35ed46a24160509c107ebff92ef281dae6091d62b14809b530c0891075487b8f65634 SHA512 fd260a4ca72148a90b78cd8ad5c7fd935aa742bb2daf1d742bdb313c2aa48c5cea35eba7278095cf4ce77fd2fb68526d0b9e2bc093110ac94d5c08930b38de4d
+EBUILD pytest-httpx-0.21.3.ebuild 776 BLAKE2B a1c687e9cb74fb1a5cec5ffd34d06f8b19d6493e8d4f838d369cd509324172eb653de36873eceaa7aaddae66c44f7d4fae278d987a47ac0659d4eaf2d51d77d7 SHA512 8303af217cc3e168552fab6015c0351620ae1247cb35d5c5bfc1995d6418d17c8e5dbd03636b699daafd6a948f173377713647a171afb3870368c54b5ff9bf37
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild
new file mode 100644
index 000000000000..fe25b787d728
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest