summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 08:02:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 08:02:07 +0100
commitf1269e587f3d88b85f72a6fbaf727da5d6c9af90 (patch)
treeec99a8c7cdea447c38d3015894c269b8bc1e95af /dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
parent3518f21ee7106f4268edf4404299dda157795e3c (diff)
gentoo auto-resync : 21:10:2022 - 08:02:07
Diffstat (limited to 'dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild')
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
new file mode 100644
index 000000000000..779e7bf2b179
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.21.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest