summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-20 12:29:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-20 12:29:37 +0100
commitd3ae3ea75073c53ed5f3a4418e76383436bb0f58 (patch)
treee7bdf993ecf567ea3b6d9c8c00797f63ae25ea02 /dev-python/pytest-httpserver
parentc59df12b8749ab7bbd5a0692072652d4fbb0d2cf (diff)
gentoo auto-resync : 20:07:2024 - 12:29:37
Diffstat (limited to 'dev-python/pytest-httpserver')
-rw-r--r--dev-python/pytest-httpserver/Manifest2
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.11.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-httpserver/Manifest b/dev-python/pytest-httpserver/Manifest
index 007ba67ffe1d..b22ba2714f12 100644
--- a/dev-python/pytest-httpserver/Manifest
+++ b/dev-python/pytest-httpserver/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpserver-1.0.10.tar.gz 60446 BLAKE2B 99d1db58f7b6fab78b687db0fc2448cbd9a3132b999e4d0ca1c8533ec2afebc717b9c28a16635260fb305aaafb832f591d28752ba3930473312a677dfaffd0be SHA512 f8636ccf757f687666a5336db66ac061ea6205979c7bbf8c9a2534282d8559453a7470318c07384aa755282c12e63537cce2ab9e9f3b2fbcda0e649ed2a45f92
+DIST pytest_httpserver-1.0.11.tar.gz 66742 BLAKE2B 641c566b2ae349bf02f9a457c488ac6820cbeabbf430d12d84ba02b09382947aa60b61a6a1578b260d160b3e8d01c37745dfd2e90bdb6aea40f546a8103b367f SHA512 3d3055bc48bbe523fddbf9e9ba3495c3141a6dcd4f8b2cf9c19f11d1e6f4a93eebe64bb920ea5bd3bc0d30f4469ecb9a8beca35fc844ca2c62f6868edcb570ee
EBUILD pytest-httpserver-1.0.10.ebuild 782 BLAKE2B 554d44ac2c780f7dfb974e7e3cb2fd3637016247e1380d02dccfd3304bd4bc82c23a091bb416e117d46056a062d53b000389618d299f2b61f73f2e7a567cabd2 SHA512 24e4b94a047d8c15746475b1fd59bec71c8700f4eb9bdd02a855f42421eae6e63973dfe45c81c725a6b849c7484dc2e04c62146685e7ec5d24289c020f0deffd
+EBUILD pytest-httpserver-1.0.11.ebuild 938 BLAKE2B 6fd828a7a85aa2a4693e2f9b13e5d90b4bf48b676204d3433dfb774f0d2a548dd0a8930991b71a2bdb10203b10332ee19ea782c743d3f127066de6ce9781a5c9 SHA512 8254eca2d4dd2337934eaa9a92f69f0599274e81624d4f6af2680e5dd10e3daebbb052251cd098b8db5f4a79b9146568097ccada4d4583d73e20bd1664717bdd
MISC metadata.xml 411 BLAKE2B 330f12d8e60a13fe3f4872f3aac04a3d62ba0314adad555e02bb5467ac7a581d3352f308ac66c9aea8b704b5f25860594017bf10ee96f5df216f6e3c10329e07 SHA512 ea6f51163452653eaa1bc9c631f5838bd9461b7c11ef2a06dd52c3d45ca9a220836b4e5e01e52bb0dbadd9bcb10a46fbec905777d0f5d9034b2f6f3cb1d6c0e8
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.11.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.11.ebuild
new file mode 100644
index 000000000000..ecf968face41
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest_httpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # confused by extra compressors available (for Accept-Encoding)
+ tests/test_log_querying.py::test_verify_assert_msg
+ )
+ local EPYTEST_IGNORE=(
+ # tests from building release artifacts
+ tests/test_release.py
+ )
+
+ epytest -p no:localserver
+}