summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
commitd117dce29795dfc5a9824d31a128decaa37f73d2 (patch)
treeef95e8fa6dfdf9a769d594a457e755c8782a345b /dev-python/pytest-httpserver
parentfa49bc1447d334c70e45ded349d3c37319dab7b4 (diff)
gentoo auto-resync : 25:02:2024 - 05:40:31
Diffstat (limited to 'dev-python/pytest-httpserver')
-rw-r--r--dev-python/pytest-httpserver/Manifest2
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-httpserver/Manifest b/dev-python/pytest-httpserver/Manifest
index 94e420d18370..de78494b9c34 100644
--- a/dev-python/pytest-httpserver/Manifest
+++ b/dev-python/pytest-httpserver/Manifest
@@ -1,5 +1,7 @@
+DIST pytest_httpserver-1.0.10.tar.gz 60446 BLAKE2B 99d1db58f7b6fab78b687db0fc2448cbd9a3132b999e4d0ca1c8533ec2afebc717b9c28a16635260fb305aaafb832f591d28752ba3930473312a677dfaffd0be SHA512 f8636ccf757f687666a5336db66ac061ea6205979c7bbf8c9a2534282d8559453a7470318c07384aa755282c12e63537cce2ab9e9f3b2fbcda0e649ed2a45f92
DIST pytest_httpserver-1.0.8.tar.gz 60126 BLAKE2B 9da65074aeca7de6a91c7afab7ac83ec8724c0595efe4abe7f3e2951ac37137c48a770ea1b5baeeb7484d647c1a03c20c86ad4de7627fb63beef174a2f7c3925 SHA512 5acff56b1c250c190da6466d398c10f206a24fe4112628ba4ec56bb2e23e21408b13d22ab6ad428e7ad7e685d7f2e73d5fc4b7afe86e7cb88d844a6e8e1a6bb4
DIST pytest_httpserver-1.0.9.tar.gz 60048 BLAKE2B 1eeecb67624d7ced713f0901c912a559e9e30c1875933cc799c3e6eca1e39941f8c556e053cc8d4a155e9c29f68d659560b0d6f51e57b97ed850b6d4ae9357ad SHA512 64d9ac47de264b0c151b17a52c904451f59e4035ad87b16a534fcccf7725b82d343736366ee3f5be03947c2f05dfb0a52bb7148014aa1a3d179748a6870e49c7
+EBUILD pytest-httpserver-1.0.10.ebuild 784 BLAKE2B 48f7159e96013b3606b2967793ff66a88cedf24fb5e537696e11e9eb571430bbabc81b7863d9e5bbc62a281e224afec5bb8438e2e1cc59fd008d2a1e3792e4f1 SHA512 642c0c10eda4d2a9cb480dc8a27261031cded33bd2df49595ae8e30232871232ae5ff5d17a5659a40c2154b65952c59dde0c1d7f9a68fa57d050d037bf76526a
EBUILD pytest-httpserver-1.0.8.ebuild 776 BLAKE2B e23c2adcb2bc29a7cab0e7337cad1e1f7d508d0ab288304751db4dd0bd4b9f4d4f5147d5f1bd77d971ccd8f8b8fb0df8acf9c1fac9855090e9cb4af8849343be SHA512 d147614fd85a2cad69d6e6f83711a6dc556a4a62217c91ffcdf054895ac5d8867cb426d4ecab7223e13cf5db8c157e5049b98c307eabece1090f63b072e482bb
EBUILD pytest-httpserver-1.0.9.ebuild 784 BLAKE2B 48f7159e96013b3606b2967793ff66a88cedf24fb5e537696e11e9eb571430bbabc81b7863d9e5bbc62a281e224afec5bb8438e2e1cc59fd008d2a1e3792e4f1 SHA512 642c0c10eda4d2a9cb480dc8a27261031cded33bd2df49595ae8e30232871232ae5ff5d17a5659a40c2154b65952c59dde0c1d7f9a68fa57d050d037bf76526a
MISC metadata.xml 411 BLAKE2B 330f12d8e60a13fe3f4872f3aac04a3d62ba0314adad555e02bb5467ac7a581d3352f308ac66c9aea8b704b5f25860594017bf10ee96f5df216f6e3c10329e07 SHA512 ea6f51163452653eaa1bc9c631f5838bd9461b7c11ef2a06dd52c3d45ca9a220836b4e5e01e52bb0dbadd9bcb10a46fbec905777d0f5d9034b2f6f3cb1d6c0e8
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild
new file mode 100644
index 000000000000..79f60d637991
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest_httpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests from building release artifacts
+ tests/test_release.py
+ )
+
+ epytest -p no:localserver
+}