summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
commit3a5772102e4f2b6f9cc46f461c90970060ae0c5e (patch)
treed5aebb2508413a75408fd60bd4cb2c886b78ba89 /dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild
parentf7379fa6ffb6e47eabc62d0d832a5bcad1db9591 (diff)
gentoo auto-resync : 14:02:2024 - 11:36:23
Diffstat (limited to 'dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild')
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild
new file mode 100644
index 000000000000..79f60d637991
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest_httpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests from building release artifacts
+ tests/test_release.py
+ )
+
+ epytest -p no:localserver
+}