summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
commitfe0961fc9674dd24a017f474a34c1edbbd005965 (patch)
treedfdf05888e0f5fff9c1faafe6eb0dd5d827b63e5 /dev-python/pytest-httpbin
parentbcd00c826070701606b0ccebf46234dfc792d3e9 (diff)
gentoo auto-resync : 19:09:2024 - 12:11:50
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest2
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index 1e483659946f..43a163cb324d 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1,4 +1,6 @@
AUX pytest-httpbin-2.0.0-certs.patch 3725 BLAKE2B 4460298caf15ee802a350cb9525942523a89812ea74482fe38a232f05dd4da440faf326ae1cf9ab6e2ff61fc17b46a5ee79b7c55640d1950a13360ec8ead15a5 SHA512 1beb28d59e520737cd13c0735c350969fd8705c2641af7fca458d9011c674a3e3e3b063035262b0ad1fcc30a09101f23bdf4badc58618d5f5bb488b13b11e3a3
DIST pytest-httpbin-2.0.0.gh.tar.gz 19799 BLAKE2B 7725bc958417c076ee920abce83bdad8295bc4c9551500040867650d54c306e79a1ea92b013124b793058103fc9685dbb2202be5f1b2da935509f68457d63d68 SHA512 62876590bacae6601739f5cc2eccb087024e16731afc9613b5e6928c2a2f64b73418ddcb3c4f13a4bfe1f074510f922d85411d05ebf66f123a4a09d535771b64
+DIST pytest-httpbin-2.1.0.gh.tar.gz 13140 BLAKE2B d1108b8464dbc1075007b4695810afe46fed17b51a785f12dfa184ba27efcfe88818ab8073c050334398eecfd647cd9169ef2d053e3fb424a02ece8a8d8c1518 SHA512 849985f170318ea3ad1d2af8811f3e3fef0e62bd6bdc611f061a8cd7d84a2d85d0ba9caf8c97298e1c99b979b08f1a28476927fa7abc1fa57334732ecfbdf2db
EBUILD pytest-httpbin-2.0.0-r1.ebuild 1282 BLAKE2B 5884fab595e91281aeab2101cf6a76a491beb4cf01a8694db609c23efa9a5ff94b797ae9cd2df61fe07c2cf1f3fffa4037a2cf925fd22e5293379992adf9e12a SHA512 91eab00fece133d0ee95b7215fe63c7d02a502caf388fc673e7ad112b69c7e54172296f16d7c9ebf94817e61ef4ed775cba07a3b17aca1a75ac9095f9c19b6bb
+EBUILD pytest-httpbin-2.1.0.ebuild 783 BLAKE2B 3174aa1cbfb122262603dc7ed4aa18a0e7be88e13b9fbc57cbf73473c0c6acdbabe77f9d821779b28cd009debeab1033fc9559cb97607f313a271c9775c5b66a SHA512 489dc7aef06317ab9411320adaadf9e9bcbf22f75712aa2ab41d857a49ffbc832bd3c58bb94eda4659df61eaac584f577658241879672951e6f1b6974e6b0ac5
MISC metadata.xml 547 BLAKE2B d60e6b3e6c7d0c37dcc42dcffeed9e08fb7ad3dec5e4f5fdc0ffd1f7a2c46d89ef57a9576028457ee433d0ecbd100ae200ef507b22bb326838732751a7c644fc SHA512 4629dfe7e4cf27d5d52e7ce3e646f590b4d80a490c638cb035352416a587b494328d3f23e088d13ae1677c415080a7249301d9830be0cfbce7a44023302bf582
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild
new file mode 100644
index 000000000000..302d6d0a6faf
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="
+ https://github.com/kevin1024/pytest-httpbin/
+ https://pypi.org/project/pytest-httpbin/
+"
+SRC_URI="
+ https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest