summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/pytest-httpbin
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest2
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild7
2 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index ccf2be5a48ac..ed0436972896 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -2,5 +2,5 @@ AUX pytest-httpbin-1.0.0-pypy3-hang.patch 1099 BLAKE2B 4bb8dd686aadc35aab144a646
DIST pytest-httpbin-0.2.3.tar.gz 9498 BLAKE2B ad41f72c80430eeea8c7f48185daf63c6adddfad36798179df27677aacc8af85419a678ba6f3df5281ca7f7ba0b3ee721cd97e5fe86eb5117417be53332f98e8 SHA512 f3c4eb67d1b02c27d8edb42622793fa3604e3f0bd5086e4986b8f0402a9fb8d7969a466be92fc6a7e301e829dbeb300183b40dccc9ec5da1d158cb4d08274f8b
DIST pytest-httpbin-1.0.0.gh.tar.gz 17813 BLAKE2B b7e0ad9f131e4d236161b66b1d6d8e6087285a6d52df1accb044b30bcdac6c5f3350e9dbfe1cf33ab64b6d6aac6b463de81c31fd12dd950426b6ed8ef4eaf289 SHA512 2794134cc005cb969752e0c1119459d3f1e106f679942880a6b9ff507f2ee31c8ac4146a9c01b9a920368ea516443954b1b7044f7b1c270fe251f7d36adf7661
EBUILD pytest-httpbin-0.2.3.ebuild 861 BLAKE2B 1595922b3716998743d8651eb5c9568c1707cbc1b41104109563077de6563a2c0eb0110eb51238345f46d0347efffcbc4f691e15e91252dda439ebf91ee776e9 SHA512 f9f14a91746be8072b8b6546679a6cae77a382c51dc5ef27b957bd3aecaee8e8c744d777d8e217f94ecc510ae98adb46c69188e829ccbb83c0b20d8ffd6c02fb
-EBUILD pytest-httpbin-1.0.0.ebuild 768 BLAKE2B 0bf7e46ee54e1464913b05270b72ec66ad36d40ea364f039d3bedab064e807d8b8ecd37feede9d27c0bfe5781b72fbc08f70639302c753f65aa14ec1c08c30dc SHA512 f50eae49938b3fbdfd06c564e594af2bb4545f91e8a5e416dd5d774dd7d7140fb5ce276f1b26cc435b097d97ef818e4b3475268d1ecb4aec40f674fe1c11ad32
+EBUILD pytest-httpbin-1.0.0.ebuild 758 BLAKE2B d19b26498718341f583f8a265a6654a1c892420ceb92a382e3af530c339eab33b3d6251e6d410ca37543b518fdf1b34ebed643e7db9605054306cedf59e4d704 SHA512 3252e3d5a1e4a7d46286ff11e8549f76e4c5aaf2de13a3e9a4e38479ef03ef721e4480006775ba081584a6d6282835c7357e0a0891c53428fc36852d9e3a7f0c
MISC metadata.xml 521 BLAKE2B f3135defad3eccac1a8f9a7188de8e375a970fd3b6c665395fad1d4ed570aa4a3a90728644fe45f13af527d5c51216e04631ddec670cb6ce5f026b508eb5f58f SHA512 19e78d9a8706ad253eb0f7873f0e8bf308065d4cdcafc6d2ebed792f31f526c1d4c45bd2f7aecac338bd30c4ebda33b301b056f3075c11231b8d0d5ad4e77d2e
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
index 6caf54c29902..d2dbd01e477d 100644
--- a/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
+++ b/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -14,14 +15,12 @@ SRC_URI="https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz -> ${
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/httpbin[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
PATCHES=(
"${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch