summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-httpbin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest3
-rw-r--r--dev-python/pytest-httpbin/metadata.xml16
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild38
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
new file mode 100644
index 000000000000..854dede82f01
--- /dev/null
+++ b/dev-python/pytest-httpbin/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-httpbin-0.2.3.tar.gz 9498 BLAKE2B ad41f72c80430eeea8c7f48185daf63c6adddfad36798179df27677aacc8af85419a678ba6f3df5281ca7f7ba0b3ee721cd97e5fe86eb5117417be53332f98e8 SHA512 f3c4eb67d1b02c27d8edb42622793fa3604e3f0bd5086e4986b8f0402a9fb8d7969a466be92fc6a7e301e829dbeb300183b40dccc9ec5da1d158cb4d08274f8b
+EBUILD pytest-httpbin-0.2.3.ebuild 875 BLAKE2B 9471269d03be53ff99daa14caaba51ecf296a4f527a580e44486529f5b5ed887a45f03358cbc8f15f7f20d813f9fbc607953aee55fb2de62e6372cea22485a0e SHA512 f308a6167ae0dcabfe8b6af7b2c2d3f7e565cde6c3f2e39e2e2715d5dcafb6cb97c1aa1186ac69f1252d484c231d927d2f44bc5d4554b2e0b9763a3f9b033cf4
+MISC metadata.xml 521 BLAKE2B f3135defad3eccac1a8f9a7188de8e375a970fd3b6c665395fad1d4ed570aa4a3a90728644fe45f13af527d5c51216e04631ddec670cb6ce5f026b508eb5f58f SHA512 19e78d9a8706ad253eb0f7873f0e8bf308065d4cdcafc6d2ebed792f31f526c1d4c45bd2f7aecac338bd30c4ebda33b301b056f3075c11231b8d0d5ad4e77d2e
diff --git a/dev-python/pytest-httpbin/metadata.xml b/dev-python/pytest-httpbin/metadata.xml
new file mode 100644
index 000000000000..a488ff2722a6
--- /dev/null
+++ b/dev-python/pytest-httpbin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-httpbin</remote-id>
+ <maintainer status="unknown">
+ <email>me@kevinmccarthy.org</email>
+ <name>Kevin McCarthy</name>
+ </maintainer>
+ <remote-id type="github">kevin1024/pytest-httpbin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
new file mode 100644
index 000000000000..14a5b50c54aa
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin
+ https://pypi.org/project/pytest-httpbin/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Not includd
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS=pytest_httpbin \
+ py.test -v -s || die
+}