summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-httpbin
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest4
-rw-r--r--dev-python/pytest-httpbin/metadata.xml16
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild37
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
new file mode 100644
index 000000000000..2bd6924bf3fe
--- /dev/null
+++ b/dev-python/pytest-httpbin/Manifest
@@ -0,0 +1,4 @@
+DIST pytest-httpbin-0.2.3.tar.gz 9498 SHA256 c5b698dfa474ffc9caebcb35e34346b753eb226aea5c2e1b69fefedbcf161bf8 SHA512 f3c4eb67d1b02c27d8edb42622793fa3604e3f0bd5086e4986b8f0402a9fb8d7969a466be92fc6a7e301e829dbeb300183b40dccc9ec5da1d158cb4d08274f8b WHIRLPOOL c7b4c1d4955389d180474aae59ad1ab3d86e1f81f84fb00fecd562c38a2a27cc741562a4f78fe7691fe978533dd8fbfd2c1b5da1a205cb996eea9bdc090c0072
+EBUILD pytest-httpbin-0.2.3.ebuild 876 SHA256 145c983d00a718781029afeec7e51841a5854925b47d9d554e9f0ab5850bd9ff SHA512 b8a9c42316f982c00ac06369b4e4e3b692997f56bbe325a1e1169b3341d1152a79238d1a8c8e7b6ef0883f0d1c23ad0fb0d46041399c0272d1a946effda6a5f8 WHIRLPOOL 8a37ece1f75d95f3b9e77b64897f0227fc5ba33a69e81d4fa53f0b1347d5a090d9f1c75acee6ce37e9e2f02a2e49ec9ee5e3a24ef304e895abd3effea6879565
+MISC ChangeLog 1791 SHA256 033c9c6c26b75e17383af46544c3c0224eaf6068743ff47ea22aee1c83a90444 SHA512 9e6f90f62ca693ad703bf323117db1f9d32dd7cf277cc3afc00c3750c5df884dbf8eea160d9308b993c930abd2354eea851c04089afd53f5b906cf6f47f5e4ca WHIRLPOOL 178fed95487014e26cd7a261a9795c84066289b03de5a8505da5d1fff2e0a5dca784db5668b2b795622b566168cb694e2d1290bb2d42ed4a1d4ca55a7eafa4d3
+MISC metadata.xml 521 SHA256 061b0b68f78a4ccd3c70906b4808296f0661fefc62ee1e5c208beb830133686b SHA512 19e78d9a8706ad253eb0f7873f0e8bf308065d4cdcafc6d2ebed792f31f526c1d4c45bd2f7aecac338bd30c4ebda33b301b056f3075c11231b8d0d5ad4e77d2e WHIRLPOOL 7e66d06351a4de0be5c4adab2841335eda8f7638fad59f4719427e792987bdff65802382fbe32aa7f7bb73404eb58822d0a2b1212317849c7f73e1bd7023ad07
diff --git a/dev-python/pytest-httpbin/metadata.xml b/dev-python/pytest-httpbin/metadata.xml
new file mode 100644
index 000000000000..a488ff2722a6
--- /dev/null
+++ b/dev-python/pytest-httpbin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-httpbin</remote-id>
+ <maintainer status="unknown">
+ <email>me@kevinmccarthy.org</email>
+ <name>Kevin McCarthy</name>
+ </maintainer>
+ <remote-id type="github">kevin1024/pytest-httpbin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
new file mode 100644
index 000000000000..70b44d52dda4
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin http://pypi.python.org/pypi/pytest-httpbin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Not includd
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS=pytest_httpbin \
+ py.test -v -s || die
+}