summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild')
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
new file mode 100644
index 000000000000..316237426a43
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin
+ https://pypi.org/project/pytest-httpbin/"
+SRC_URI="https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch
+)
+
+distutils_enable_tests pytest