summaryrefslogtreecommitdiff
path: root/dev-python/pytest-html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pytest-html
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pytest-html')
-rw-r--r--dev-python/pytest-html/Manifest4
-rw-r--r--dev-python/pytest-html/pytest-html-1.22.1.ebuild7
-rw-r--r--dev-python/pytest-html/pytest-html-3.1.1.ebuild29
3 files changed, 36 insertions, 4 deletions
diff --git a/dev-python/pytest-html/Manifest b/dev-python/pytest-html/Manifest
index e347264e3698..104a680e62d4 100644
--- a/dev-python/pytest-html/Manifest
+++ b/dev-python/pytest-html/Manifest
@@ -1,3 +1,5 @@
DIST pytest-html-1.22.1.tar.gz 28183 BLAKE2B bf6d2aecda8fd3117a7b58307f1246e2d6f31f8939812c402d541c13dc329d7e7a0ab1f72ea70583d39614599d70dd0f4ffcc00b0d481ae4bbfce968f016adb3 SHA512 8adf1b1a27ea9f635226acdcd9d429bf78dc57ef9a67cf6616868c60b921c0cef117a63f4ef4c258350900759b607baa71d2a6b73cc8f9f718b405a7fba0d5e4
-EBUILD pytest-html-1.22.1.ebuild 770 BLAKE2B 28fa3c350c849bfe56c0b7a4ffef7c46cff5ab1bca6a3c8980a8489af1df36df86a37ed588b1940e714964425e6f3ac61188d25d725b84a6d9213a2391c2777e SHA512 5613f4842e0c680539d50cc23ed9ed82afbc03b8ba6ed1f5e35c82a939e4aada5811277a8a88f40202c6a43949d4633b7467abf98ac55c69d6edcf68c33da03f
+DIST pytest-html-3.1.1.tar.gz 38548 BLAKE2B d2491280ceb4524a10a46891448bb63fe997a4be82062e727fb1d79ef6154a0b4229bbec27c6601372776f7c8dd124aab5d4968482fc24ad24330db5d2520187 SHA512 78091b485d153b54cd76abb8cfeb6494830b1b51a10dc0c00c73eccf67962d2805e3f83972c7ccfd1f877a939b582f80d5ddd5273fd1ddcac2a1a9c2eb121300
+EBUILD pytest-html-1.22.1.ebuild 766 BLAKE2B 0fc51c4a08707ac42a044419a616facf129da938ffbe5878e2bda023b84f336a49ddd807001a230f081b58626c91554445ce24a3cd18e223f7c4edcef8da5055 SHA512 7e7324e09222c1a8b85336093dd0be956180112398e1a990a9e70b08e1742a3f9505fa1a5d74e0c8029ddd7312b3c2e4f2be9ed4b7f338c3d98251846c39a6f3
+EBUILD pytest-html-3.1.1.ebuild 766 BLAKE2B aa4daa33743fb37f34c08a1ba0d168941f11867710768d37e4c7b4fbb32c30ba8e29253662c6aa0a8898476c64e94df9dfbf6ee750f2454fac5be211b3a3f9b3 SHA512 e8bf10971acbe3f24fe63eb678ff79d12a1bf2e1fed01aec3fa9fe58695940164c48c7d53699f7bd2c4e6517263e9b09d6da48b7fd1544ced9353a2aee4bd7f3
MISC metadata.xml 354 BLAKE2B 0c9325132cb715771e8b3b7f0cf8d24d3752d9499e4968722a413a319a4600c4647ebb39f95a3ce930d4649f8351b75272a0201c74c1add2a7f258916e8eccd8 SHA512 196fd5d73634e0dfd0c33c4c26d82b1dc8cfa905414d201c806a19a8c82254d512c31984744a7978a39903391844700745b45e25f2a762c8a9bbf203b839ed57
diff --git a/dev-python/pytest-html/pytest-html-1.22.1.ebuild b/dev-python/pytest-html/pytest-html-1.22.1.ebuild
index ff9bd0ca538c..46e90071e9a8 100644
--- a/dev-python/pytest-html/pytest-html-1.22.1.ebuild
+++ b/dev-python/pytest-html/pytest-html-1.22.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
inherit distutils-r1
DESCRIPTION="Plugin for generating HTML reports for py.test results"
@@ -13,9 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
# Lots of test failures...
RESTRICT="test"
+
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-metadata[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
diff --git a/dev-python/pytest-html/pytest-html-3.1.1.ebuild b/dev-python/pytest-html/pytest-html-3.1.1.ebuild
new file mode 100644
index 000000000000..052856b3ca2f
--- /dev/null
+++ b/dev-python/pytest-html/pytest-html-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Plugin for generating HTML reports for py.test results"
+HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Lots of test failures...
+RESTRICT="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-metadata[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test -v -r a testing/test_pytest_html.py || die
+}