summaryrefslogtreecommitdiff
path: root/dev-python/pytest-helpers-namespace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-helpers-namespace
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-helpers-namespace')
-rw-r--r--dev-python/pytest-helpers-namespace/Manifest2
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-helpers-namespace/Manifest b/dev-python/pytest-helpers-namespace/Manifest
index 5b9c1692e32a..3d8a7c490a08 100644
--- a/dev-python/pytest-helpers-namespace/Manifest
+++ b/dev-python/pytest-helpers-namespace/Manifest
@@ -1,4 +1,6 @@
AUX pytest-helpers-namespace-2021.3.24-remove-extra-dep.patch 1218 BLAKE2B 1126c43aa209aa989f969e9ef04e1ddbd9502b697f46f4920234f022b380f5098f06b12fd1b9aae42d29ee61480f0db617af261da01b6ce2cf749e4b20fc06b9 SHA512 67fac2cd8ff09b6e104ceb2c7c239316444a9ac9e361ca2dfb152118bf540ab64eb336dd6a02a2c30a1579d47f3aad64789a5f95f9298f28a696219312af1bc6
+DIST pytest-helpers-namespace-2021.12.29.gh.tar.gz 51376 BLAKE2B cbc79e6868a18f7174b96e73e3e902ea969d5a361c141e12bf5a67eeb7c93cead61629842f8b8744e58240cd8b85f9864ed95fec7ce048446963592b41bbd7e5 SHA512 82c231ff11a36fce7b16a0ceea51c9306f7e05ca3f9e8cc7cc1c77ac9822f974d1ac893d2bf9b7154bf9593a529193daa041ccaaced6fdd9e38ba4f794f161b0
DIST pytest-helpers-namespace-2021.3.24.gh.tar.gz 25881 BLAKE2B d13e82eebf09b4acb1d8fb9d3609f8814a49bfd0df56f23fe6f3fe3fa1508c4f1ac338b3f75e1e97ae90f71cae548dd100548d23cdbaa6c4bdb76cdb6e3d4a41 SHA512 1914427a4805a168d4067cd5db5663d28e3ff680f612e70a169a7efbc6c2c7ba0e2dc74132595aa70e13b651886bd10a6947e56558edf22b871618c967537073
+EBUILD pytest-helpers-namespace-2021.12.29.ebuild 1004 BLAKE2B f2a9352607b11b77539231e5c01a2b03801009d07906e901353e76347164d14348bc386066d766d5ef872f08eb67b1df528c40b858e5be195f765e273c22c821 SHA512 ee3d8c720069f4f3745bae4a6ef382adc6b0a5d25e6e7f5a694bf7253d5a4a05ce9db8bc68186a77f427f0dd2ac8e49f435968cdb4ee395fd47c1d4420326419
EBUILD pytest-helpers-namespace-2021.3.24.ebuild 819 BLAKE2B 18b08e19e531e108b235a6795dedd86b46b9ad7fdd2d26521a8a825fead3461586a516e93d9f045a50f6f837d5ab511a09fc691e8057c364fedff98bf2b69187 SHA512 452ac5e8c6a884c25218b1aa5f549688edb972560822534d35edafdb49574a5efd7e4b42fb2c03b983b08f646a6e5e70a71fb530d343c6e7cdb04107b8fec588
MISC metadata.xml 514 BLAKE2B d2cf552d0b34b0556bffdb2afb6524b5c0ce81d503a6a1dc2b4957beea0c96c1eb3ea4f6e61bd4351a26fa2983d10b155a58bbf04fcfba1fe4e55f720a7db09a SHA512 9aa9a28164597c7a6bec22f6c07f269c5954b02a4a7523373866e60f2d6824c83dd4912ca2e05081a2257f7e01e135f2544a0732d3c2f51266b331c753314108
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29.ebuild
new file mode 100644
index 000000000000..8475898d5ed5
--- /dev/null
+++ b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides a helpers pytest namespace"
+HOMEPAGE="
+ https://github.com/saltstack/pytest-helpers-namespace/
+ https://pypi.org/project/pytest-helpers-namespace/
+"
+SRC_URI="
+ https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-declarative-requirements[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_helpers_namespace.plugin
+ epytest -p pytest_forked --forked
+}