summaryrefslogtreecommitdiff
path: root/dev-python/pytest-helpers-namespace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/pytest-helpers-namespace
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/pytest-helpers-namespace')
-rw-r--r--dev-python/pytest-helpers-namespace/Manifest4
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild36
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild19
3 files changed, 38 insertions, 21 deletions
diff --git a/dev-python/pytest-helpers-namespace/Manifest b/dev-python/pytest-helpers-namespace/Manifest
index 22854625f6fe..57401793bd2b 100644
--- a/dev-python/pytest-helpers-namespace/Manifest
+++ b/dev-python/pytest-helpers-namespace/Manifest
@@ -1,3 +1,3 @@
-DIST pytest-helpers-namespace-2019.1.8.tar.gz 5487 BLAKE2B 201e2e34f60baf95ce33f8cb5d3d8ce5465b4140e68c16f4802ba5225e28c4506c608dfc6ff4a36fddde30c7972a8c175ead976a11a731e2bfbc33e4b06cc04e SHA512 47b7f7c6638f4f3f0248722d4134b73357acb091f02cc1302d32894223d5ec06fd5382db207ae524f62749f2ebc53cf32d27eb8890d12baf250cd29dc6378a55
-EBUILD pytest-helpers-namespace-2019.1.8.ebuild 459 BLAKE2B 7134e603fcfd9f2476b66730dc666a99f0bf3d39db764f6168716f8d96395d1aab21d10f29788e24fbcb7d007aae03eb96a12935fba18c0efa88988eec016a66 SHA512 54cf5df849e46cda1ced740c018b778d783f546eae05c6f3a9c256f14914548a0807a685a3e04d217974210dfe9d18928c59eb96f9d997a4dd74e03e1682faad
+DIST pytest-helpers-namespace-v2019.1.8.tar.gz 10274 BLAKE2B 1d232817e99909738f7f37466ba22fbeadf75f4fbfdd9b61790dd79418bedbce4ee219e5102ee2db1709ba991e323ce6edffc68c4e3a657c58cb628b505de098 SHA512 d5f4db3ece8b0e1719c4d1213a5e07a3c53257b089d3d74f90cf86f21a7951983a95286c7753f5e9486acc7e482d79c2a95d5a7b8eb22e19c7048db99fa3c421
+EBUILD pytest-helpers-namespace-2019.1.8-r1.ebuild 853 BLAKE2B 044c9d7fe1f0acfa8a1068e1371bb5397ccf37e907aefb47dfd3c45d8dbb69b5510e8cfb579cc9f3f22953e9888096f79a2d79a5f357b299bd490e75be96615b SHA512 416e10275ec5f2dee4b917edd9523920aff7de66399e734b40894d54b56539503c848d51fefe4b5ab1b45b8e3de2f10719b817649502cdfa3e5a245dd240e5ea
MISC metadata.xml 328 BLAKE2B fab884918d24353a3281a69d6ce042faa916c0fa3b8e33d6acac90e85b487f31d97388d64ab59257b0e9cb1aaa8891c7934f87e4b5a2f36a5f0cb621e937f264 SHA512 7cbdc338820fd09b283ef5686c59a1a7138a3b1e0b315daa0d6e4e4e0cf1f87b1802128ab03939ce24fa1b97954de7fd34096f9d734bf20e1ee8e99276e95941
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
new file mode 100644
index 000000000000..1883af6e3263
--- /dev/null
+++ b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Provides a helpers pytest namespace"
+HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:(foo|bar):namespace_\1:g' \
+ -i tests/test_helpers_namespace.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest --forked -vv || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild
deleted file mode 100644
index 5df845c7031a..000000000000
--- a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides a helpers pytest namespace"
-HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"