summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/pytest-forked
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/Manifest2
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index 80b435b7150a..f608643de557 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1,3 +1,5 @@
DIST pytest-forked-1.3.0.tar.gz 9850 BLAKE2B cbe44d87052c5a3bc58934ac17153401810004aaa38b53ff3100384535cb2ea0fa99dada706113f324fa0a135ddbd9b97488319b4a9554d912388c341b62943c SHA512 25d639aa43380155d7744f1d05a95e0144f5fe7dea42ff3c2bba3803a07d73b5eb008525469330c5dda14800fe4b611241691be197132f31f88f66930c3ecac0
+DIST pytest-forked-1.4.0.tar.gz 10197 BLAKE2B 7a6ec42f7ad1323eea243739a9186fb87eac3016afef844ec39a6e3fd55f7d40b1410fcc27074624f8468e6dabddffcc22ea0597bbbd898fab71c82c06e25b46 SHA512 ba402aec6dbec7a94815913192a49390b637a123d3557f48d809ae2e871e9e0cff8f9d0feb99e2bd06fe9486520b5e539f397d39475a720f8283b1bd21c751c7
EBUILD pytest-forked-1.3.0-r1.ebuild 935 BLAKE2B 55fa6f0134ca91c17164c797b60f9742ca28b8d93d15af25a2c8a7239f78e44f22edcd4949d06a5fee5c227be9051ac8a7c895c433e1ea4ced1d35bf2c87bc84 SHA512 5bed1117b5d7575785d36e13e2a51e5d89d531cc3eccef7ed99b804e821b477c1479dc2aca51a37613cf2ead610dcbfe3579dbdfc37547ac68cd1a9a32a87a88
+EBUILD pytest-forked-1.4.0.ebuild 860 BLAKE2B afbf7a639e559b6a680ed30f9d9d593e83a4f8fd94328d1642f8dea3b4acb85c8ff6364789bec6a825f0546e283cf21aa51a7f06ccced272bc28cd43d92f654d SHA512 747de247c4f72720419c7294b59f552fb06893dff1392b1a22b5e6bac34b7cefbaf7b13538835c8a92826cb38d98e8bccfd5a793366d0eda76b6a68c3d8e65d3
MISC metadata.xml 405 BLAKE2B 8cb6b3e3b440bc53f5d02a9638b00356f64bc02a8d7444ec5e295fcf91507f94c2460acd02008e6b11ca3bc2dd3d2f96ffb61c583fade0ff4ca00a182c01f903 SHA512 4a1dda1d8ada98b57881884ec6e982c308b54ab29e2cfa104f398876a1bd8ee2015dc7de4891c305f65030e30259079667d42c7a80d14d5148feeb5b7cf5904f
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
new file mode 100644
index 000000000000..c65d14f14759
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
+RDEPEND="dev-python/py[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ epytest -p no:flaky
+}