summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-forked
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/Manifest3
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild36
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0.ebuild2
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index 69a6bfbe590d..fd3f97450994 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1,3 +1,4 @@
DIST pytest-forked-1.4.0.tar.gz 10197 BLAKE2B 7a6ec42f7ad1323eea243739a9186fb87eac3016afef844ec39a6e3fd55f7d40b1410fcc27074624f8468e6dabddffcc22ea0597bbbd898fab71c82c06e25b46 SHA512 ba402aec6dbec7a94815913192a49390b637a123d3557f48d809ae2e871e9e0cff8f9d0feb99e2bd06fe9486520b5e539f397d39475a720f8283b1bd21c751c7
-EBUILD pytest-forked-1.4.0.ebuild 852 BLAKE2B 770a1d2950c06fd6cb6ad6596df0f9558b1b853053e0eeddc3b926b3452fb8d87b4bb6078ae52e054cdfab25cb65f26424a713d0b636c7adb9eac4d9d6c3d882 SHA512 fcd0e427a1342120c83b2fd96977cf2ca3d6ed2e23bdc381f49d5183ca20bdd980555a4e74a48bbfcacb2fe9eb66fea6a3ff9a035aaa1885d2649db2a5616e8f
+EBUILD pytest-forked-1.4.0-r1.ebuild 880 BLAKE2B 3a62ed89df80f90dcf53fb8ab178b54d770ed398cf493d2f22af519fad081cf156c4f7387a964d5a27782ff780837023fe6a89aa6623a6748dca917dce45db0a SHA512 5e6604608d3fc54828ce76f3659a8775febf431e635ecd4d372d8367f381ab7e68d895d3c249dd17488ed1aa79c479f794311d0591a0ce95b3f383d36caf1620
+EBUILD pytest-forked-1.4.0.ebuild 859 BLAKE2B 2a4b583da28bccde55d824c12639d32d29075360968a7df675d14910bdc1f4cea285ffbbf44cc4a5e8f63454656c4f17aa20bd62baaa1033f87dc8db4c06dafe SHA512 aa50686dc2f08725ce50a2b281688bacb9152198ce9cf14e1b0af51a8a6c1830db1cd7805e3332a2e5841f1c2cb185788cef41238dc677dc73e7cf00f967fb51
MISC metadata.xml 405 BLAKE2B 8cb6b3e3b440bc53f5d02a9638b00356f64bc02a8d7444ec5e295fcf91507f94c2460acd02008e6b11ca3bc2dd3d2f96ffb61c583fade0ff4ca00a182c01f903 SHA512 4a1dda1d8ada98b57881884ec6e982c308b54ab29e2cfa104f398876a1bd8ee2015dc7de4891c305f65030e30259079667d42c7a80d14d5148feeb5b7cf5904f
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..ad4a61224380
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="run tests in isolated forked subprocesses"
+HOMEPAGE="
+ https://pypi.org/project/pytest-forked/
+ https://github.com/pytest-dev/pytest-forked/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
index 0a182595e8c9..a9f3ffc010c5 100644
--- a/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
# Please do not RDEPEND on pytest; this package won't do anything
# without pytest installed, and there is no reason to force older