summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild b/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild
deleted file mode 100644
index 1047da546dfa..000000000000
--- a/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="run tests in isolated forked subprocesses"
-HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Please do not RDEPEND on pytest; this package won't do anything
-# without pytest installed, and there is no reason to force older
-# implementations on pytest.
-RDEPEND="
- dev-python/py[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-3.10[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing
- epytest -p no:flaky
-}