summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/pytest-flake8
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/Manifest2
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
index 08b9b103e47f..2e3f4dd31e96 100644
--- a/dev-python/pytest-flake8/Manifest
+++ b/dev-python/pytest-flake8/Manifest
@@ -1,3 +1,5 @@
DIST pytest-flake8-0.8.1.tar.gz 7359 BLAKE2B fd45d50fa68e329569a5964407fae301075907aabf0ec2c85c7ad9b9c28aa7a92acfaf9b7b4e06036c940ca6c7a35388cefb0d9b9151471fe98c968a43cf5a95 SHA512 b49b4d42712040492161f144cce807b661f2d8fe5b484b29ad1a519fd5b0b0cfb6abd42c3ae8999f21263c4776fb773f91bf0776971b6b6727607d33fb49ca89
+DIST pytest-flake8-0.9.1.tar.gz 7959 BLAKE2B d0ef55385dbbf47968abdfc14e69a0420cd52bdf65c0f74ec72abeb1ab28ad27806593dd592f448f3c01dcdf29af4042c1e1c8affde46a1405ba7b4155c174a4 SHA512 eeb4f66022e367d92dee94544ae8fa99b79c1de0579a80e91c22e6f050752010cb7ad6c24094736d23ae753615b186a957b8b0f94c09754005183a971a1e4aa1
EBUILD pytest-flake8-0.8.1.ebuild 613 BLAKE2B 981a2cbc44d772261fe2a8add725ea471a21159cf8ec1668f0e7161cd75d115b77bf0ade024febacc5ef445f609b6011fe07ac8256b227d5de8bbee89f0611e4 SHA512 e61b58a8a58ebc933b9285b8dee54e96f3758acb63b3fafb06d8ebc9d2fb5d22a97106cd1d1cf94dd87de5456b8ead9dbf714c243e2d69c4a6ad4a540485153a
+EBUILD pytest-flake8-0.9.1.ebuild 681 BLAKE2B 53b2611ee82040d4acc5f50c91ada4ed7ca37807ca463677434bef9b2af87b1e16a8a5c526212078cf3a4cbbeb06eb1e459219430f5a5bf9cc092b92324ef4b8 SHA512 41e91fb531c26672fc9e1906605f192eec0d07169ddd6fee56c7975bd1a735a292a727c11e318a0e27ddaa0e07bc8d32ba7e84f78c5ab1ee0dc664b2893aa532
MISC metadata.xml 507 BLAKE2B 75290d0db230e858a4b5b706a2636963a998c882631cd2599bfca3a1961a2f6304dd67b1fa2dbf5a278a86dda00a4c50247f400ff8573845552d3f11b2704595 SHA512 0f022aea078d7eb1b41db5326bf4c1b950344102f4b614ef095e20555a81032687a3312ead75ff33ee8f6dcc81984651dfc110b95113b8c4f2b3e57f52e97baa
diff --git a/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild
new file mode 100644
index 000000000000..9b0fa3e9c971
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flake8-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pytest -v || die "tests failed with ${EPYTHON}"
+}