summaryrefslogtreecommitdiff
path: root/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild')
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..c94a4af4d0ac
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="https://github.com/gsnedders/pytest-expect/ https://pypi.org/project/pytest-expect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# no tests...
+RESTRICT="test"