summaryrefslogtreecommitdiff
path: root/dev-python/pytest-env
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-08 12:29:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-08 12:29:28 +0100
commit8e49340ce0aaf205556648d8fa27dd30e8cf4435 (patch)
tree38cc25a0f12067b6b184788983173496ae9936e6 /dev-python/pytest-env
parent6c1090c8458fa6e15fd24227293d60bbf356eb60 (diff)
gentoo auto-resync : 08:09:2024 - 12:29:27
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest2
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.4.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index 9fba95e021e1..d2bad6555818 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1,3 +1,5 @@
DIST pytest_env-1.1.3.tar.gz 8627 BLAKE2B 04aee8a84b2224ce1f0bb018d0d5a8f8542d32aa3e3da0ed03afdace2562b1643f712152128f7d673e118a4db9ab10c7440f44728ba774519ceb989b4c9be7f2 SHA512 c38371a272987757774bed6b566b55ba2304ca37e69f3f5671fb03735bbdfe5e51c3b03cd885d6bdbd73496daa95a57d79e03bf5d9171f0e9c5c0ae38492b304
+DIST pytest_env-1.1.4.tar.gz 8898 BLAKE2B 8e6d9af2de86af47b5429e64112f7bbd4824fa54a7ffd2a7deb63da2032f6104587594a9efcddfc56a4dd7ef969b1a6cb4150906c029437c960ad02b0e215513 SHA512 9cde819b4f68f1a19de58c86651427c608b160bdfb6b6e12c6f4b90f195a759573e442d92df08f70b807282d4b47a7c078fa0b4674433d8778a9b8fb5552209e
EBUILD pytest-env-1.1.3.ebuild 804 BLAKE2B e0a4cd49201b578ac9df7586f9f5a1dfca23f6e964fc8aced714befdba3ef5f1ddedb0edf1b40d2dcccd004e067ad2231c9ac80153e259caeebe3b0b362c4081 SHA512 bfed7133cd76c35677a0955612faa00f92188eda86e37fb2d02107fa6abe6bedbe828ddeb8eaa1f0e8502f5e5cb4ab773dab0bf10cd2e22a407f8d9309034e83
+EBUILD pytest-env-1.1.4.ebuild 943 BLAKE2B 8135dcab5bd7a76146fcb591da1ee97349869b7779e2203fe3e97dbdb2f52653a75163454d221a82230d688412970d46a86ab44f744f167e63ccb07f49f94814 SHA512 7a66b2f55ef647ca5658e42905953ef547ec4d0d3631d85444941b3700e9d0b4ee36a7391af2c44b3f44c771c3336a6629368dd5e92254ffe3191b9f5a5e865a
MISC metadata.xml 399 BLAKE2B 15d67070d9ef65f186a5f67370347ed3a8eff0cbb81f292c3beb78ae34b336227de60d9fbd18ee30ead66a7d11a14910c166b961efde1e52a8aa24051f7f1ecc SHA512 a0271a2d9ae0ff90f3f1356ece7c0a95232a75b9dff094caad01758e837301152f8d7b10d8d8e228e0bd8daeece779b9d07294334e0e2067884c0b3cf09c9106
diff --git a/dev-python/pytest-env/pytest-env-1.1.4.ebuild b/dev-python/pytest-env/pytest-env-1.1.4.ebuild
new file mode 100644
index 000000000000..bfda9aab1b32
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # upstream lower bounds are meaningless
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}