summaryrefslogtreecommitdiff
path: root/dev-python/pytest-env
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 09:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 09:47:15 +0000
commit4241e2d11b148ec5e384070a86c12f7ad7b1884d (patch)
treec3e9f8d9d0e1fe023d4b1f48dc51ac7b09e8c5cd /dev-python/pytest-env
parenta4d738a9d1fddef251ba88e258acdb50c243fa63 (diff)
gentoo auto-resync : 31:10:2023 - 09:47:15
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/Manifest2
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
index 902271e2b33f..b180a5eaeffc 100644
--- a/dev-python/pytest-env/Manifest
+++ b/dev-python/pytest-env/Manifest
@@ -1,5 +1,7 @@
DIST pytest_env-1.0.1.tar.gz 7565 BLAKE2B 26aa1c6a5d44bbe40266bbb62ca62c687dd1d85aed821c271f301ff27a97fdc753d2cdf5feba8b223b33b5b05bf39c55c3df0f1f8f7aae77335f2052a65df6c0 SHA512 422aaa78e25fad7b447f06358b772cacf22d5441ae0aaac22863877424f44703c1329813b068d901d4f2fb9df21bb08a5e4082504b76102d02dd15087d527a01
DIST pytest_env-1.1.0.tar.gz 8640 BLAKE2B 384b438c6a5da2ddeac0be1a601b74eca77abbe5b5100322f9f161f5e68119980370aa1c8f8160ca9db53628209742afabd981678784e2c42a1f527344c39558 SHA512 12fb8d1093f9d9e89a2bb543428086cba04a322a4d443960d3ab33f270a3aa8f98585c334091d90febe3a5f4d4d66111dd5a8a5a7322185af10cae3eae14bfde
+DIST pytest_env-1.1.1.tar.gz 8625 BLAKE2B e455f4183a7c423895f69e8a598c2fd312594501855b650008960cd94757aed4e2cf96302974bd68777a4a75e4363e3facc77ac9ac8a79f11f709f172852d105 SHA512 dffe17d1e7a2f0a8d26fd13ebc5f87ee834f03cbcf9870899952c306bdefafd9b3bc8f6120142c22d82cace28ee6b681e40b8eb71cd3c77781bf56c269c28feb
EBUILD pytest-env-1.0.1.ebuild 718 BLAKE2B 8386abe8049acbc7067c7f6ffd60869364a5700d9f5ca1bb9f9b4e4c3bd59b03204b621e3dc1724f44efa04ba8bb0bd1fc7b598c39755eba4e783455dce8b861 SHA512 c3358a3cd6f9c6f73590cd7ac64c99ad3e6f2a03d735b9011e2922ef7df3f8bf6417c238af26cea0eca1d8cbffb7393603b7d98285a9e79b7cf2ad88d99d1e7c
EBUILD pytest-env-1.1.0.ebuild 807 BLAKE2B ce4fe9142be5f37784c9f907de9debbad7e914f31021755eb99fdca01ff3f4642ba817cbf12df77a0459467ce417b40006a653c6c4f32d8179f9346450ed6afa SHA512 433766fd936179fdfca7f8d42e7363a78795d48d8388f6bf4668c4ce755c33320b1bcff16e5d366afe1e470d8319ade025ab51ea1743cbada7c22f4ea29406f0
+EBUILD pytest-env-1.1.1.ebuild 807 BLAKE2B ce4fe9142be5f37784c9f907de9debbad7e914f31021755eb99fdca01ff3f4642ba817cbf12df77a0459467ce417b40006a653c6c4f32d8179f9346450ed6afa SHA512 433766fd936179fdfca7f8d42e7363a78795d48d8388f6bf4668c4ce755c33320b1bcff16e5d366afe1e470d8319ade025ab51ea1743cbada7c22f4ea29406f0
MISC metadata.xml 505 BLAKE2B 00369d63ea894a5d1b493461b41f5a211219dba4aee1e53a5bfcd4e37fb181ebb7f4934e721c186a5d631f3f03a8bbea2b1d732a1206b2347beb71b03f0c84a0 SHA512 78e7bf0e52d709686f0302ee3ffb2d11ff85860586a42aa23e974f60bf675de919d9d78fa0aa80d66b779b1575936686bf2846830ef4bea25e4ed87d2ce05835
diff --git a/dev-python/pytest-env/pytest-env-1.1.1.ebuild b/dev-python/pytest-env/pytest-env-1.1.1.ebuild
new file mode 100644
index 000000000000..407864cef54b
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}