summaryrefslogtreecommitdiff
path: root/dev-python/pytest-env/pytest-env-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 16:31:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 16:31:33 +0000
commit8cd3c41aa0ccead302235680b9e2fa9903d7548e (patch)
treeb6f2658c42bd34d0f1dc8b5f572aa5f5886c3d5d /dev-python/pytest-env/pytest-env-1.1.0.ebuild
parent2900e684ae4bdce1f20652587728095cd01a30a1 (diff)
gentoo auto-resync : 25:11:2023 - 16:31:33
Diffstat (limited to 'dev-python/pytest-env/pytest-env-1.1.0.ebuild')
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pytest-env/pytest-env-1.1.0.ebuild b/dev-python/pytest-env/pytest-env-1.1.0.ebuild
deleted file mode 100644
index 407864cef54b..000000000000
--- a/dev-python/pytest-env/pytest-env-1.1.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="pytest plugin that allows you to add environment variables"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-env/
- https://pypi.org/project/pytest-env/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-
-RDEPEND="
- >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}