summaryrefslogtreecommitdiff
path: root/dev-python/pytest-env/pytest-env-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 01:36:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 01:36:25 +0100
commitdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (patch)
treea62738c03c7054c5e9671a2f1d43542b84db1bfa /dev-python/pytest-env/pytest-env-0.8.2.ebuild
parentf2381eb1a950bcf1b75077ca00e589b06a905cc7 (diff)
gentoo auto-resync : 28:06:2023 - 01:36:25
Diffstat (limited to 'dev-python/pytest-env/pytest-env-0.8.2.ebuild')
-rw-r--r--dev-python/pytest-env/pytest-env-0.8.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pytest-env/pytest-env-0.8.2.ebuild b/dev-python/pytest-env/pytest-env-0.8.2.ebuild
new file mode 100644
index 000000000000..db479a2c1572
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-0.8.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="py.test plugin that allows you to add environment variables"
+HOMEPAGE="https://github.com/pytest-dev/pytest-env"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND=">=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest