summaryrefslogtreecommitdiff
path: root/dev-python/pytest-env/pytest-env-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 09:53:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 09:53:29 +0100
commitcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (patch)
treeba764e9926b855c14e54b63112216041a4ab7e51 /dev-python/pytest-env/pytest-env-0.8.1.ebuild
parent1bb02f2ca2710df2358072c9a036ae83d2ece88c (diff)
gentoo auto-resync : 25:10:2022 - 09:53:29
Diffstat (limited to 'dev-python/pytest-env/pytest-env-0.8.1.ebuild')
-rw-r--r--dev-python/pytest-env/pytest-env-0.8.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-env/pytest-env-0.8.1.ebuild b/dev-python/pytest-env/pytest-env-0.8.1.ebuild
index 3ab29754ad80..2c0cc5da7303 100644
--- a/dev-python/pytest-env/pytest-env-0.8.1.ebuild
+++ b/dev-python/pytest-env/pytest-env-0.8.1.ebuild
@@ -3,16 +3,20 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="py.test plugin that allows you to add environment variables"
-HOMEPAGE="https://github.com/MobileDynasty/pytest-env"
+HOMEPAGE="https://github.com/pytest-dev/pytest-env"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/hatch-vcs[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest