summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pytest-django
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-4.4.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index aa51f4817133..09a77a1b4531 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,5 +1,7 @@
DIST pytest-django-4.2.0.gh.tar.gz 68370 BLAKE2B 94165a01ecd2734a4e02267ecfe8b531df33ca9237cfcd1ebad41f68289fb89590bed0027137d6dddefc4cbbd5c0f8445703e01a516d3992c2307ebe53d6572b SHA512 2dcaa80f3ebb67984d3849cea5de296388990ca65a607f995b89bd67e2d8964f944100bccb42a32bb75c7009849619e50421c2dce077037ce0440233dbdc13f1
DIST pytest-django-4.3.0.gh.tar.gz 71525 BLAKE2B 0eba9d9917759369aa2e126539f17fc36874453caf59838be2baf660fe29487aa80490f2af4ecbd72a9ba1f63a8a87202af2eff7e9d28c9c0fc686b09b07e82a SHA512 3c3ac31ed75daa29ab473ef3b87b5c66333cf7ccd8d217eb120b7899f463aafe5982b1e867e26e3b9ab51f312612fbc3d9f1ed9169815507816267fd4de76757
+DIST pytest-django-4.4.0.gh.tar.gz 72905 BLAKE2B 4532bef9afdc7f11fdf9a16f019810d10e4e580b517958722184d361a69a195f6c66f7f3bc18be6cb7f63fe4576963c59a00d72bd8a42f104d26e5ad091c6d54 SHA512 47e4a84606aeb6bb99ed74603faf988298d52f81f74ec8e4608cb670f0f331ad0c6555f3e4a516fc7834aea4e634f849dc0ff6d446a86e924a116fbe90bd79e0
EBUILD pytest-django-4.2.0.ebuild 818 BLAKE2B b27be5e4ef794426900ad4997bfeee3437f326baf706945efcec9679f1969435a96aa5c5ad58051ded1834bdcd4e20dc3e000643f20bc06c6a2ea7a935b0d089 SHA512 103a3ede84e5f4110a89abd25bbd0ed4b7d5d860399e912e7b1673e046b58a35c1ff21e4ee9e3a4647e1d4f5a01f7c75a0278f46033d1a5cdb34441e7e9051cb
EBUILD pytest-django-4.3.0.ebuild 822 BLAKE2B e9e861b673e839e5262cf9665322d9fe5cf86b67447f725e6ea2ae4c023cde24e59236b0ed4b7bffc25c15b35770bba5c8aca4812e61f9ac0db91990e89a91af SHA512 78f4fa922dc9bc5865adc46b8bfb64ee4b4b584273b8bbbbd3ba5eaffe826c547646b38948de725f28397cd6f97039629e574038f1453c774979a2a1275a3dc5
+EBUILD pytest-django-4.4.0.ebuild 1271 BLAKE2B d60738c48fc7d5094c743dae9891a8ff13cba1eb02e1e8c6e0835a59f26fdddea28e297b99dc5fec8a75d0aea2dbacad25fac8903f274aa4d04af0d46cc26a6e SHA512 fd1609b9fd9d762c45f063c29ffd00c02005fd15383edacb013a2e5fcf1c536d0c526b35096d48a98a76e2b7b1791e25c0d9d6887a9e4e6e3da062667456e082
MISC metadata.xml 404 BLAKE2B 24556c59793b77f5c6de6f5c1210575d7bf7b5dc55aa7427d630d21311a77b31e3c846d5198ebf9b0407a0b1a36eae17bbd37a988c376eda666680871de30ea6 SHA512 33db1ea8ab6490e9b09daf334f48aa8db16db565e264b47b120797aee63c08c99aa27cae3c0a55a21c87552f99ad1ba9a13ba3b53e4562608209efb87a227268
diff --git a/dev-python/pytest-django/pytest-django-4.4.0.ebuild b/dev-python/pytest-django/pytest-django-4.4.0.ebuild
new file mode 100644
index 000000000000..4244bb555380
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-configurations[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # something else may be loading it
+ tests/test_django_settings_module.py::test_django_not_loaded_without_settings
+ )
+
+ distutils_install_for_testing
+ cp -r pytest_django_test "${TEST_DIR}"/lib || die
+
+ local -x DJANGO_SETTINGS_MODULE
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests ${deselect[@]/#/--deselect }
+ done
+}