summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
commitc9388864702fdd7b0b56c049eddb41bdb9054dcb (patch)
tree3595822471cd11e6f9f92565ab81ab9c5ee39c3f /dev-python/pytest-django
parenta41f630aea0b4b71a6c9a088571f1eaaf8413d53 (diff)
gentoo auto-resync : 30:10:2022 - 15:03:33
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest3
-rw-r--r--dev-python/pytest-django/files/pytest-django-4.5.2-pytest-7.patch30
-rw-r--r--dev-python/pytest-django/pytest-django-4.5.2.ebuild6
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index f8dbf1add92f..f735c657e8b7 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,4 @@
+AUX pytest-django-4.5.2-pytest-7.patch 1363 BLAKE2B 167e9fe999261fbf39985de8da87e551d08c9e855812bfc3b35c0a8f6c4c64bb99c2dbc9e706714cb20258da30072420841b033fd71e3157a8821a728be8b0c3 SHA512 9e57788693cdbd472d45c6f40190514a90d7b2d067fd8bfa95938ffbd0471bc9855266f2027368f3ae51bc5f03f743fab65b986c830f450bf72a3269ca17f1d1
DIST pytest-django-4.5.2.gh.tar.gz 75429 BLAKE2B 2e8fba037c7618c6dd1c9200c5c44a7b00a13a2d70b4a593a461af3dbc0333b6814ceca16f88a58f1b6aeea2700cac12b589ede702b8eaf023fb3948e0ab8b9a SHA512 09ed5bfe850599e95190d9b15e9383d1249ea575a7b3921744583da6266dd2c8d3eb4f93c8de96d98e1a8e33d1639937470cdc6d11558fcaea57d014dce13500
-EBUILD pytest-django-4.5.2.ebuild 1264 BLAKE2B 5eafb92d7e738ae39a966ef50940f064620c4684255b0733717b0343dd6d11b27fa66e41715bec0e30b6c5f2276fd866b4f9944ed3201150bd869472044365f8 SHA512 b13d6a0266b0eb5fcd9f793b885ea711252d780dea6b39deaad8c93072f2f2480a4bea5aa0d09387ced752c93e3d3e29323b15b35814b8a7b4a35c53fdd29bd7
+EBUILD pytest-django-4.5.2.ebuild 1312 BLAKE2B be90cd6b42439db68f2e826bd17dcf97f4a2e647e6cb7e253ba931a5d77549f869d03e61be6c20b8e63669516c853ffe698aa5d4367c161fba8740619ff27a23 SHA512 9edcdcb809578cd18301870c3f985da8120a5005fd1e02da347346104093cfe8fbeee004e8784b942c17e4eb8a2b9f6726229bbc34c365858ae86d1edfe0d45b
MISC metadata.xml 405 BLAKE2B 973e3124eed7a497154d1160e5e1350503b2599a3111968329f0b01496ce1eb6b84b76aeddb427478ffd470aa8aee4102e5598b3406b8d2dbd01703cd9adbef8 SHA512 6d7a6a7e084283cd6564be193a43c80f0599c4aa98ad68a98e656f9f1aa7103cd6164acf040c1e71415e28ebe707b013f92bcf4f2f5139ee873ee20408aed150
diff --git a/dev-python/pytest-django/files/pytest-django-4.5.2-pytest-7.patch b/dev-python/pytest-django/files/pytest-django-4.5.2-pytest-7.patch
new file mode 100644
index 000000000000..657e5fa617a2
--- /dev/null
+++ b/dev-python/pytest-django/files/pytest-django-4.5.2-pytest-7.patch
@@ -0,0 +1,30 @@
+https://github.com/pytest-dev/pytest-django/commit/14b993d1cb291bfcf05f35f57db55c0419886534
+https://bugs.gentoo.org/834815
+
+From 14b993d1cb291bfcf05f35f57db55c0419886534 Mon Sep 17 00:00:00 2001
+From: Stanislav Levin <slev@altlinux.org>
+Date: Mon, 28 Feb 2022 13:12:37 +0300
+Subject: [PATCH] tests: Sync expected stream for Pytest's version
+
+https://docs.pytest.org/en/7.0.x/changelog.html#breaking-changes:
+> [pytest#8246](https://github.com/pytest-dev/pytest/issues/8246): --version now writes version information to stdout rather than stderr.
+
+Fixes: https://github.com/pytest-dev/pytest-django/issues/995
+Signed-off-by: Stanislav Levin <slev@altlinux.org>
+--- a/tests/test_manage_py_scan.py
++++ b/tests/test_manage_py_scan.py
+@@ -118,7 +118,12 @@ def test_django_project_found_invalid_settings_version(django_testdir, monkeypat
+
+ result = django_testdir.runpytest_subprocess("django_project_root", "--version", "--version")
+ assert result.ret == 0
+- result.stderr.fnmatch_lines(["*This is pytest version*"])
++ if hasattr(pytest, "version_tuple") and pytest.version_tuple >= (7, 0):
++ version_out = result.stdout
++ else:
++ version_out = result.stderr
++
++ version_out.fnmatch_lines(["*This is pytest version*"])
+
+ result = django_testdir.runpytest_subprocess("django_project_root", "--help")
+ assert result.ret == 0
+
diff --git a/dev-python/pytest-django/pytest-django-4.5.2.ebuild b/dev-python/pytest-django/pytest-django-4.5.2.ebuild
index c8c2f52aae18..5ef63f301424 100644
--- a/dev-python/pytest-django/pytest-django-4.5.2.ebuild
+++ b/dev-python/pytest-django/pytest-django-4.5.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A Django plugin for py.test"
@@ -30,6 +30,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-7.patch
+)
+
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
distutils_enable_tests --install pytest