summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/pytest-django
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-3.10.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 3e10db82b844..f82648487638 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-django-3.10.0.gh.tar.gz 68995 BLAKE2B dcc9ddceda88c32dab559c065feb347582e72ec5fcd9929cb2bde091bd5c89bbe09879901daf5dc0adc7e38921de5b4989e0d1bbefaa5eb1cdce1dfd2ef58a11 SHA512 7f66fa9287fb80082018613ec3b15a0da3f7a13075e85f0a2eff9e13358c993e56245c441d952d13f232bf7e49a05c799b4affbb844e90abaac736d86bb0a6c9
DIST pytest-django-3.9.0.tar.gz 70498 BLAKE2B 0f3cf7ffd528f00dd0c7dd6babcb64833ec3684c7b62dcb8757b0f90cdcdddabffdbff240774ed6fb2a294e27da2acd7f396298ff2884be6e5b4c8d9c632d008 SHA512 92985e66f47c91363d19fe2bfe8ccab14212be577692f90923dbbae4c8d406cf698796d485af2b721863392810fc07c6f11ada0c61589cd1861f0d34a732effe
+EBUILD pytest-django-3.10.0.ebuild 823 BLAKE2B c1a76f9442190c12b95448cdfca27664ee5be6a3a1428f426c0081d4545c5d6fb194e38806e711cfd75aa61ff487440a075db31b05712b679e384ca0901395f5 SHA512 f66c00d35964d95b6fa516711866bbc38b02d94172f77cb679f6832313aac6c98490b3c135afbd830e3c1f5fb6045c932f81f6f73bdd423c4908339c8a72459b
EBUILD pytest-django-3.9.0.ebuild 727 BLAKE2B e3cb064747983e53a3e9245a2cbc872f3ba1545b89047a81143bd103407ea8d942b7fe0423b3038216eb42e591302bf360570be407be1edcf78a8c20aaff58e7 SHA512 da6f7f1481b82c9380485c595ac74baa46dace9b059e5fc56abaa9924b08c87e9debddc50e7c2cac532c0b06ffa19d5ce5b8ae5ebf55850a8a5f3240f33ea702
MISC metadata.xml 404 BLAKE2B 24556c59793b77f5c6de6f5c1210575d7bf7b5dc55aa7427d630d21311a77b31e3c846d5198ebf9b0407a0b1a36eae17bbd37a988c376eda666680871de30ea6 SHA512 33db1ea8ab6490e9b09daf334f48aa8db16db565e264b47b120797aee63c08c99aa27cae3c0a55a21c87552f99ad1ba9a13ba3b53e4562608209efb87a227268
diff --git a/dev-python/pytest-django/pytest-django-3.10.0.ebuild b/dev-python/pytest-django/pytest-django-3.10.0.ebuild
new file mode 100644
index 000000000000..0dbf356c69a9
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.org
+ https://github.com/pytest-dev/pytest-django"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}