summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-30 21:45:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-30 21:45:44 +0000
commit77922838ba6e7b5f546528626d41f2e7f3fc2c08 (patch)
tree1fd5f253063a75764253e522032b50626e1a508e /dev-python/pytest-django
parent691395139ec5ea80983f870451c53bb6fff8298a (diff)
gentoo auto-resync : 30:10:2023 - 21:45:44
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-4.6.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index e597103bd7ec..6a0aa9ed6e42 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,4 +1,6 @@
AUX pytest-django-4.5.2-pytest-7.patch 1363 BLAKE2B 167e9fe999261fbf39985de8da87e551d08c9e855812bfc3b35c0a8f6c4c64bb99c2dbc9e706714cb20258da30072420841b033fd71e3157a8821a728be8b0c3 SHA512 9e57788693cdbd472d45c6f40190514a90d7b2d067fd8bfa95938ffbd0471bc9855266f2027368f3ae51bc5f03f743fab65b986c830f450bf72a3269ca17f1d1
DIST pytest-django-4.5.2.gh.tar.gz 75429 BLAKE2B 2e8fba037c7618c6dd1c9200c5c44a7b00a13a2d70b4a593a461af3dbc0333b6814ceca16f88a58f1b6aeea2700cac12b589ede702b8eaf023fb3948e0ab8b9a SHA512 09ed5bfe850599e95190d9b15e9383d1249ea575a7b3921744583da6266dd2c8d3eb4f93c8de96d98e1a8e33d1639937470cdc6d11558fcaea57d014dce13500
+DIST pytest-django-4.6.0.gh.tar.gz 77499 BLAKE2B 057eb0f3593aed92285d96edbcff94cab5ec1574c394793199df4b93bfb3256b723ae74689a6413f7a2303b8c5564e40805f4e9ee6ed2dead1030d8da3a4f7ed SHA512 e2dc2a1993b795cc15f6d63757a9c01b2f466812f69f07aa43deff8260edcd881da554a200b0d793173a2fa9efd826f020e2ba1c26931fa2f59503d25ce7c240
EBUILD pytest-django-4.5.2-r1.ebuild 1376 BLAKE2B bc85f9ec2fda83e6682e7604cd20069605cdafa9361815311c33314c36eae616b861689c951a2222a54ffbf9e1e38d64903570b81b250aea7916ac8487d3870c SHA512 3ef9ae7d304db7e7e7bac065ea2f51de608cef555bae87c9fa817c93472befc1be41071d690fed53314b4151708a27676ca6b5c4c3c82aae1fb56b92033023e9
+EBUILD pytest-django-4.6.0.ebuild 1246 BLAKE2B 278b0a29f75b3c363168a2790ad364dfd2a3f9a6f37da485593174774dab2f8166f8741133a2bf548d425109c333933ac345cc31709850bb3e197909025cf97a SHA512 682ea577319a7f6e879af83139096933d40f2f1555420c1424c1c5d34923486dfaefd0544bc3a0a79cd454ca40eb006144b20ecdeecc4f9f5bef139548797758
MISC metadata.xml 405 BLAKE2B 973e3124eed7a497154d1160e5e1350503b2599a3111968329f0b01496ce1eb6b84b76aeddb427478ffd470aa8aee4102e5598b3406b8d2dbd01703cd9adbef8 SHA512 6d7a6a7e084283cd6564be193a43c80f0599c4aa98ad68a98e656f9f1aa7103cd6164acf040c1e71415e28ebe707b013f92bcf4f2f5139ee873ee20408aed150
diff --git a/dev-python/pytest-django/pytest-django-4.6.0.ebuild b/dev-python/pytest-django/pytest-django-4.6.0.ebuild
new file mode 100644
index 000000000000..9148fdfba396
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for pytest"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/django-configurations-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE
+ local -x PYTHONPATH=${PWD}
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_django.plugin,xdist.plugin
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests
+ done
+}