summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-django
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest4
-rw-r--r--dev-python/pytest-django/metadata.xml12
-rw-r--r--dev-python/pytest-django/pytest-django-2.9.1.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
new file mode 100644
index 000000000000..8ff2cc87b55f
--- /dev/null
+++ b/dev-python/pytest-django/Manifest
@@ -0,0 +1,4 @@
+DIST pytest-django-2.9.1.tar.gz 50570 SHA256 8be15b637738c8cbd1422a6461465c0aeab7839cf76ad2b5d190b6f1f53facd6 SHA512 0e50f45a0cfefb6fa74f7d60d5173e3e8dac49ac669c9c88e46d27a01cff5c4a255d6f707863406b6f8707e25e9bea3408cbffbb75a2680fee365b9c9167d468 WHIRLPOOL b7992224d0cfb655c9faf0af9689a6bdd2c9371114c875f2b1a00e6d972a487346cb6939eac0b04d24b302311d1795696f5c38e362f832a84416d2a0d23b501d
+EBUILD pytest-django-2.9.1.ebuild 930 SHA256 7934cbf089c5e1b4f47397899608d02904830332e5369d021bbadec439224023 SHA512 1733c9fdc6790bb5471162a3d16ba0e5e892448d0938d0a16a7f0a0fb52aa767ef7efcf69ad9754b90e17ea81adff157b5555313fd244f168201c11a7a2fc7e4 WHIRLPOOL 0f7e829490daf332d1d303d850ef0edce74489ad70e742c568915d08455318682c7ffec263645638851510abd7dd6a3a36c65f9b727dfa0ecc737847aa43a75b
+MISC ChangeLog 1561 SHA256 c3355abb56d42f1b604722a96689a559b816af6d2d0184c0f16271fbc4dccce0 SHA512 de20ea52710c9dd850d05219dfd809c4bc134dcf0072decde97aa3e853d588e12d506cfb723f955f7d9599412b8a9c4a192778eb2bd2e35fe0f62b6ff5c561fe WHIRLPOOL e92f1e6d9b967bac9848ba985b8f9b12aca408b5c5f20a67189f7cfb365991ab2a25a5089effd222c9c97f94d25d34ec1ac7e1313e38ae7d19fde9cfd27db822
+MISC metadata.xml 380 SHA256 69e12dbe72e7ba54a02698d7e50ed9029b2651210bcc4544abdd8983822419b7 SHA512 65163d6f99c4d2be86bbedad07b756eda2aa639cd612e0ffaf95dc0707e72de8b406ad51d2a482925790c837bc7c3d4ccd5dc3fd070da6599e13278db03ab006 WHIRLPOOL 33c1a1cf15d0b5b3895a19207501e189860a83abca3fa3390ede116075c4d27574865d9ede6032d86d862779fd1a9fb7256f5769a5303017f27b55975248181d
diff --git a/dev-python/pytest-django/metadata.xml b/dev-python/pytest-django/metadata.xml
new file mode 100644
index 000000000000..6cc31041286c
--- /dev/null
+++ b/dev-python/pytest-django/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-django</remote-id>
+ <remote-id type="github">pytest-dev/pytest-django</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-django/pytest-django-2.9.1.ebuild b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
new file mode 100644
index 000000000000..4e1da3ba941b
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-django https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.8.0[${PYTHON_USEDEP}]
+"
+
+# https://github.com/pytest-dev/pytest-django/issues/290
+RESTRICT=test
+
+src_prepare() {
+ sed \
+ -e '/setuptools_scm/s:==1.8.0::g' \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test --ds=pytest_django_test.settings_sqlite_file --strict -r fEsxXw || die
+}