summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
commit28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (patch)
tree6d6b6b0a1aca19e8118845870c9e6a25bad27963 /dev-python/pytest-django
parent840a65e2af3f2cc7527e723a28f6e627a9592fb7 (diff)
gentoo auto-resync : 30:01:2024 - 17:49:05
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-4.8.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 488a6fa1e637..2d67b78a2427 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,5 @@
DIST pytest-django-4.7.0.gh.tar.gz 77146 BLAKE2B 7e5b0c1bc1e3953794f39cf425150a4963acab44295a23d3ee67147d3b6bdb66b56de165caae6ba2cfaa083e9b2de9c13ead699cee46008afeded65ba743b3d3 SHA512 090337442568b43e9da4ec2b3d0c1f862e44c90a3852906338928a968e4fa89ef9e9e930f43d067e48dde317aeba465ec374be9d5ec74c835ad7e1cea9cba93b
+DIST pytest-django-4.8.0.gh.tar.gz 77646 BLAKE2B 206357110066d233c103755cfd6324e8042d9c93442c25db17a13f02132eab60a315856441e26d43a3c493cf72ce39ef51163ccc5368941875e63656bf9122a7 SHA512 8f7ba6b28cc4c0347876beb85247ccd021767811b9122c8cd0fb5d051df4ae76267b27a3fee5c36882a40716bdcbaab43abf71ef8dd61757087b12fd141632aa
EBUILD pytest-django-4.7.0.ebuild 1242 BLAKE2B 46b07eb468f134b1aeaae1e12ba23da333529ba68a9861937617d06233feedab2186565798d244496bc421b44747337204618e5b2b5041a1564b40d3936c72f4 SHA512 3e5a73b934f865b15d25ca1bddfa3284552b6663ad16519bb2848b54d3750cf8c2a7a469eb9135a53ffe7a5b6910df8ca9ddbc211e95e3cd9d97c040907c16c4
+EBUILD pytest-django-4.8.0.ebuild 1246 BLAKE2B 7c449e67f16aacc1e82d368abb6ef682c6ac4270eb163ab01b2fbb98f79dbc009cd374276934d9d625e826c30474589caac6ce5528c781512ae3c294106d6c90 SHA512 b90dd21fc03a677e1bad96b6a95847c857b3e72464ea9d59d66ea51679388018d20b1f04bd4a7a348926d7d563568e6b6c3a7c4979ef953f89674bb13c6734c3
MISC metadata.xml 405 BLAKE2B 973e3124eed7a497154d1160e5e1350503b2599a3111968329f0b01496ce1eb6b84b76aeddb427478ffd470aa8aee4102e5598b3406b8d2dbd01703cd9adbef8 SHA512 6d7a6a7e084283cd6564be193a43c80f0599c4aa98ad68a98e656f9f1aa7103cd6164acf040c1e71415e28ebe707b013f92bcf4f2f5139ee873ee20408aed150
diff --git a/dev-python/pytest-django/pytest-django-4.8.0.ebuild b/dev-python/pytest-django/pytest-django-4.8.0.ebuild
new file mode 100644
index 000000000000..d58ce450e940
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for pytest"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/django-configurations-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE
+ local -x PYTHONPATH=${PWD}
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_django.plugin,xdist.plugin
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests
+ done
+}